Erreur apt lors d'une mise à jour

JustBmwEz - Modifié le 14 mai 2024 à 12:09
mamiemando Messages postés 33173 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 10 juillet 2024 - 14 mai 2024 à 12:15

Bonjour,

Pouvez-vous m'aider a installer mes paquets, car quand je fais :

sudo apt update

... ça m'affiche ça : 

Ign :1 cdrom://Xubuntu 22.10 _Kinetic Kudu_ - Release amd64 (20221018) kinetic InRelease
Err :2 cdrom://Xubuntu 22.10 _Kinetic Kudu_ - Release amd64 (20221018) kinetic Release
  Veuillez utiliser apt-cdrom afin de faire reconnaître ce cédérom par votre APT. apt-get update ne peut être employé pour ajouter de nouveaux cédéroms
Ign :3 http://fr.archive.ubuntu.com/ubuntu kinetic InRelease
Ign :4 http://fr.archive.ubuntu.com/ubuntu kinetic-updates InRelease           
Ign :5 http://fr.archive.ubuntu.com/ubuntu kinetic-backports InRelease         
Err :6 http://fr.archive.ubuntu.com/ubuntu kinetic Release                     
  404  Not Found [IP : 2001:bc8:1600:4:63f:72ff:feaf:a2de 80]
Err :7 http://fr.archive.ubuntu.com/ubuntu kinetic-updates Release             
  404  Not Found [IP : 2001:bc8:1600:4:63f:72ff:feaf:a2de 80]
Err :8 http://fr.archive.ubuntu.com/ubuntu kinetic-backports Release           
  404  Not Found [IP : 2001:bc8:1600:4:63f:72ff:feaf:a2de 80]
Ign :9 http://security.ubuntu.com/ubuntu kinetic-security InRelease            
Réception de :10 https://brave-browser-apt-release.s3.brave.com stable InRelease [7 547 B]
Err :11 http://security.ubuntu.com/ubuntu kinetic-security Release      
  404  Not Found [IP : 2620:2d:4002:1::103 80]
Err :10 https://brave-browser-apt-release.s3.brave.com stable InRelease
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 0686B78420038257
Lecture des listes de paquets... Fait
E: Le dépôt cdrom://Xubuntu 22.10 _Kinetic Kudu_ - Release amd64 (20221018) kinetic Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt http://fr.archive.ubuntu.com/ubuntu kinetic Release ne contient plus de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt http://fr.archive.ubuntu.com/ubuntu kinetic-updates Release ne contient plus de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt http://fr.archive.ubuntu.com/ubuntu kinetic-backports Release ne contient plus de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt http://security.ubuntu.com/ubuntu kinetic-security Release ne contient plus de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
W: Une erreur s'est produite lors du contrôle de la signature. Le dépôt n'est pas mis à jour et les fichiers d'index précédents seront utilisés. Erreur de GPG : https://brave-browser-apt-release.s3.brave.com stable InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 0686B78420038257

Merci d'avance 

JustBmwEz
 

A voir également:

2 réponses

laurent2m-l Messages postés 1442 Date d'inscription lundi 21 septembre 2009 Statut Membre Dernière intervention 30 mai 2024 700
14 mai 2024 à 00:50

Bonjour,

update (commande recommandée : sudo apt-get update) permet de récupérer la liste des mise à jour en consultant les dépôts.

En général, l'on saisit dans la foulée, sudo apt-get upgrade, afin de les appliquer au système.

Le plus gros problème, dans votre cas, c'est que vous utilisez une version obsolète de Xubuntu : il n'y a plus de mise à jour, d'où les erreurs.

Une nouvelle installation est impérative. Soit vous optez pour Xubuntu 22.04, maintenue jusqu'en 2027, soit vous sautez le pas avec la toute récente 24.04, qui pourrait connaître de petits problèmes de jeunesse. A vous de voir...

Les versions en support à long terme (LTS) sont toujours préférables : elles sont fiables, prévues pour 5 années de mise à jour.
On les repère avec leur numéro de version correspondant à sa sortie en année paires et en avril, d'où l'annotation : (20)20.04, (20)22.04, (20)24.04...
Les autres versions non-LTS sont plus éphémères...

Ok merci beaucoup de ton aide !

0
mamiemando Messages postés 33173 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 10 juillet 2024 7 761
14 mai 2024 à 12:15

Bonjour,

Quelques compléments de réponses :

  • La durée de vie des différentes versions d'Ubuntu est reportée dans ce tableau. On voit effectivement que Ubuntu 22.10 est obsolète depuis le 20 juillet 2023 et que les LTS, comme leur nom le suggère, ont une durée de vie plus longue.
  • Il est possible de passer d'une version donnée d'Ubuntu à une version supérieure. C'est ce qu'on appelle une migration. Cette étape pouvant parfois mal se passer, je recommande aux personnes qui débutent de sauver leur données quelque part au cas où.
  • Au pire, il est toujours possible de réinstaller Ubuntu tout en conservant une partition /home existante. Il faut cependant être vigilant au moment de partitionner les données (il ne faut pas formater /home sous peine de perdre les données qui s'y trouvent).

@JustBmwEz est-ce que tu as toutes tes réponses sur ce sujet ? Si oui, merci de basculer le sujet en résolu.

Bonne chance