Eliminer les doublons d'une formule NB.SI.ENS

Manue_3825 Messages postés 4 Date d'inscription lundi 2 octobre 2023 Statut Membre Dernière intervention 3 octobre 2023 - 2 oct. 2023 à 11:00
Manue_3825 Messages postés 4 Date d'inscription lundi 2 octobre 2023 Statut Membre Dernière intervention 3 octobre 2023 - 3 oct. 2023 à 11:40

Bonjour,

Je bloque sur une formule (cf image). Je cherche à éliminer les doublons sur une formule NB.SI.ENS pour la création d'un dashboard : dans mon fichier, je souhaite calculer le nombre de procédure en "phase nationale" (colonne D), déposé sur 2023 (colonne E) par dossier en enlevant les doublons de ligne qui se génère par pays.Merci pour votre aide.

A voir également:

2 réponses

DjiDji59430 Messages postés 4023 Date d'inscription samedi 19 avril 2008 Statut Membre Dernière intervention 9 avril 2024 641
2 oct. 2023 à 11:51

Bonjour à tous,

Il est d'usage de joindre un fichier exploitable, pas une photo.(par le meme canal qu'en dessous) et de preciser sa version d'excel

Avec un tcd

https://www.cjoint.com/c/MJcjZd4yFrY


Crdlmt

0
Manue_3825 Messages postés 4 Date d'inscription lundi 2 octobre 2023 Statut Membre Dernière intervention 3 octobre 2023
2 oct. 2023 à 12:00

Merci pour le retour. C'est la première fois que j'utilise ce forum.

Voici le lien du fichier : 

Et la version d'excel Microsoft® Excel® pour Microsoft 365 MSO (Version 2308)

Et le lien vers le fichier: https://www.cjoint.com/c/MJcj4HTsc2w

0
bigoudiii Messages postés 212 Date d'inscription lundi 19 décembre 2022 Statut Membre Dernière intervention 10 avril 2024 75
Modifié le 2 oct. 2023 à 14:06

Hello,

Peux-tu préciser sur un exemple ce que tu entends par doublon de pays. Pour le dossier 4209 quel résultat veux-tu 1, 2, 5 ?

Edit : après réflexion, essaie  :

=NBVAL(UNIQUE(FILTRE(A2:A9254;(E2:E9254>=J2)*(E2:E9254<=K2)*(D2:D9254="Phase nationale"))))

ou si tu peux avoir un résultat vide :

=SOMME(N(UNIQUE(FILTRE(A2:A9254;(E2:E9254>=J2)*(E2:E9254<=K2)*(D2:D9254="Phase nationale");""))<>""))

Formules valables pour Excel 365

1
Manue_3825 Messages postés 4 Date d'inscription lundi 2 octobre 2023 Statut Membre Dernière intervention 3 octobre 2023 > bigoudiii Messages postés 212 Date d'inscription lundi 19 décembre 2022 Statut Membre Dernière intervention 10 avril 2024
3 oct. 2023 à 11:20

Super, Un grand grand merci. C'est exactement ce qu'il me fallait.

Une dernière question : Peux on adapter la formule pour avoir les phases nationales et régionales?

0
Manue_3825 Messages postés 4 Date d'inscription lundi 2 octobre 2023 Statut Membre Dernière intervention 3 octobre 2023 > Manue_3825 Messages postés 4 Date d'inscription lundi 2 octobre 2023 Statut Membre Dernière intervention 3 octobre 2023
3 oct. 2023 à 11:40

En fait, j'ai trouvé:

=+NBVAL(UNIQUE(FILTRE(A:A;(E:E>=J2)*(E:E<=K2)*((D:D="Phase nationale")+(D:D="Phase régionale")))))

Un grand grand merci!

0