Valeur à un mot

Fermé
Oli - 4 janv. 2023 à 19:38
Willzac Messages postés 267 Date d'inscription mercredi 27 septembre 2017 Statut Membre Dernière intervention 21 décembre 2023 - 10 janv. 2023 à 10:12

Bonjour,

J'ai créé un fichier feuille de temps Excel.

Je suis en train de butter.

Lorsque je la complète avec les durées (heures d'entrée et de sortie), tout fonctionne à merveille.

Par contre lorsque j'ajoute (férié ou vacances), mais formule ne fonctionne plus.

Je souhaiterais donner des valeurs à ces mots afin que mes formules soient fonctionnelles.

Toutes les heures et les textes sont dans une liste déroulante.

Merci, 


Android / Chrome 108.0.0.0

4 réponses

The_boss_68 Messages postés 917 Date d'inscription dimanche 15 novembre 2015 Statut Membre Dernière intervention 27 février 2024 172
4 janv. 2023 à 19:44

Bonjour,

Un fichier EXCEL anonymisé complété par des explications compréhensible
mis sur https://www.cjoint.com/ permettrait aux intervenants de répondre plus précisément à ta question.

Slts
 

0

Bonsoir,

Comme demander, je joins le fichier.

Merci,

 https://www.cjoint.com/c/MAfakOhJLpT

0
Raymond PENTIER Messages postés 58247 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 27 février 2024 17 104
Modifié le 5 janv. 2023 à 04:26

Bonjour.

Ton tableau m'interpelle sur de nombreux points :

  1. Pourquoi écrire =(C5-B5-D5)+E5+G5+I5+J5+K5+M5+O5+Q5+R5 en S5 au lieu de =SOMME(C5:R5)-B5-D5 ?
  2. Pourquoi des formules différentes le lundi et les autres jours ?
  3. Pourquoi mélanger en colonne B l'heure d'entrée et le statut de la journée ? Il suffit d'avoir 2 colonnes séparées, et ton problème sera réglé !
  4. Pourquoi ces colonnes vides, en F et H ?
  5. Pourquoi "Temps de pause" en D4 mais "Temps régulier" en D13 ?
  6. Dernière anomalie : Pourquoi renseigner la colonne D, avec une durée qui sera soustraite (donc avec un total négatif, ce qu'Excel ne reconnaît pas), lorsqu'il n'y a pas eu de travail ce jour-là ?

0
Willzac Messages postés 267 Date d'inscription mercredi 27 septembre 2017 Statut Membre Dernière intervention 21 décembre 2023 89
Modifié le 10 janv. 2023 à 10:13

Bonjour, 

Retire la référence B14 de ta formule dans la cellule S14 et tire ta formule vers le bas

PS : Il faut que vous apprenez a utiliser la fonction "SOMME()"

Cordialement

Willzac


0