Moyenne incrémentée excel

Fermé
JVH1325 Messages postés 6 Date d'inscription vendredi 9 décembre 2022 Statut Membre Dernière intervention 10 décembre 2022 - 9 déc. 2022 à 10:07
JVH1325 Messages postés 6 Date d'inscription vendredi 9 décembre 2022 Statut Membre Dernière intervention 10 décembre 2022 - 10 déc. 2022 à 08:25

Bonjour,

J'ai un fichier de données (environ 120000 lignes) qui sont des valeurs (mesures) dont j'aimerais faire une moyenne par 10 lignes pour ne plus avoir qu'un fichier 10x plus petit.

Je devrais faire les moyennes séparément sur 2 colonnes. J'essaie de me débrouiller avec la fonction décaler mais je patauge et me noie.

Pouvez vous m'aider?

Un grand merci d'avance


Macintosh / Safari 16.1

A voir également:

7 réponses

yclik Messages postés 3605 Date d'inscription vendredi 25 juillet 2014 Statut Membre Dernière intervention 17 mai 2024 1 483
9 déc. 2022 à 10:50

Bonjour

une piste

en B3

=B2+10

en D3

=SI(B4="";"";MOYENNE(INDIRECT("A"&B3&":A"&B4)))
0
JVH1325 Messages postés 6 Date d'inscription vendredi 9 décembre 2022 Statut Membre Dernière intervention 10 décembre 2022
9 déc. 2022 à 11:40

Bonjour,

Merci pour votre réponse, mais j'ai essayé de l'appliquer et j'ai des résultats incorrects, mais je me trompe peut être sans le voir. je voudrais vous envoyer un extrait de mon fichier mais je ne sais pas comment faire.

0
yclik Messages postés 3605 Date d'inscription vendredi 25 juillet 2014 Statut Membre Dernière intervention 17 mai 2024 1 483
9 déc. 2022 à 11:43

re

Bonjour


1) Aller dans https://www.cjoint.com/
 2) Cliquer sur [Parcourir] pour selectionner le fichier (15 Mo maxi)
 3) Aller vers le bas pour cliquer sur le bouton bleu [Creer le lien Cjoint]
 4) Au bout de quelques secondes la seconde page s'affiche, avec le lien en gras ; faire un clic-droit dessus et choisir "Copier le lien"
 5) Revenir dans la discussion sur CCM, et dans votre message faire "Coller".

0
JVH1325 Messages postés 6 Date d'inscription vendredi 9 décembre 2022 Statut Membre Dernière intervention 10 décembre 2022
9 déc. 2022 à 12:45

Bonjour,

Voici le lien vers mon fichier https://cjoint.com/c/LLjlRUGI2cK

0

Bonjour,
Vous pourriez essayer ceci :
https://cjoint.com/c/LLjmnvlf1Oo
Cordialement.

0

Suite :
Avec une petite macro pour les 200 premières lignes, à titre d'exemple...
Cordialement.

https://cjoint.com/c/LLjomuzKuqo

0

Suite :
Et peut-être serait-il judicieux de découper votre tableau en plusieurs fichiers, 44.642 lignes ce n'est facilement gérable...

0
JVH1325 Messages postés 6 Date d'inscription vendredi 9 décembre 2022 Statut Membre Dernière intervention 10 décembre 2022
10 déc. 2022 à 07:04

Bonjour Arthur-92

Vos liens ne s'ouvrent pas??

Mon fichier est aussi découpé dans différents onglets (je ne l'ai pas partagé) reprenant les données jour par jour. le fichier de base fait 527040 lignes et effectivement c'est quasi ingérable, mais c'est le problème de certains appareils de mesure.

Il a donc été fortement élagué pour ne reprendre qu'une période significative.

0
Arthur-92 > JVH1325 Messages postés 6 Date d'inscription vendredi 9 décembre 2022 Statut Membre Dernière intervention 10 décembre 2022
10 déc. 2022 à 07:54

Re-bonjour,
Je n'ai pas eu de problèmes pour ouvrir votre fichier, mais il n'est pas facile d'y travailler dessus...

0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
yclik Messages postés 3605 Date d'inscription vendredi 25 juillet 2014 Statut Membre Dernière intervention 17 mai 2024 1 483
9 déc. 2022 à 18:00

bonsoir

A tester

0
JVH1325 Messages postés 6 Date d'inscription vendredi 9 décembre 2022 Statut Membre Dernière intervention 10 décembre 2022
10 déc. 2022 à 06:56

Merci, l'idée y est mais il reste une erreur et c'est ce que j'avais constaté lors de votre première réponse. en effet le calcul que vous proposez fait la moyenne des lignes 2 à 12, puis 12 à 22 puis 22 à 32 etc ce qui fait qu'une ligne est reprise à chaque fois dans 2 calculs, la ligne 12 dans la première moyenne et dans la seconde, la ligne 22 dans la seconde puis la troisième et ainsi de suite. L'erreur est minime mais perturbante à certains points du tableau.

En tous cas je vous remercie beaucoup pour vos efforts

0

Bonjour,
Une version modifiée.
Cordialement.
https://cjoint.com/c/LLkgLANFC1o

0
yclik Messages postés 3605 Date d'inscription vendredi 25 juillet 2014 Statut Membre Dernière intervention 17 mai 2024 1 483
10 déc. 2022 à 07:58

Bonjour

et avec cette formule en D3

=SI(C4="";"";MOYENNE(INDIRECT("B"&C3+1&":B"&C4)))
0
JVH1325 Messages postés 6 Date d'inscription vendredi 9 décembre 2022 Statut Membre Dernière intervention 10 décembre 2022
10 déc. 2022 à 08:25

Bonjour,

le résultat est parfait, je vous remercie mille fois. J'apprends tous les jours, mais la matière excel est si vaste...

0