Formule RECHERCHEV Excel

Résolu/Fermé
Sophie8959 Messages postés 4 Date d'inscription jeudi 20 octobre 2022 Statut Membre Dernière intervention 21 octobre 2022 - 21 oct. 2022 à 15:07
Sophie8959 Messages postés 4 Date d'inscription jeudi 20 octobre 2022 Statut Membre Dernière intervention 21 octobre 2022 - 21 oct. 2022 à 15:45

Bonjour,

Je sollicite votre aide sur une formule Excel de recherche de mot. J’ai une colonne A dans laquelle se trouve des noms répétés plusieurs fois et une colonne F qui ressence ces noms avec un numéro associé (en colonne E). Je souhaiterais retrouver en colonne B le numéro associé à chaque nom mentionné en colonne A en allant se référer à la colonne F. Pour cela j’ai appliqué la formule suivante :

=RECHERCHEV(A;$E$1:$F$30;1) mais cela me renvoie la valeur N°4 sur la totalité de la colonne B.

Voyez-vous quelle peut être mon erreur ?

Je vous remercie.

A voir également:

3 réponses

diablo13800 Messages postés 2890 Date d'inscription jeudi 2 juillet 2015 Statut Membre Dernière intervention 16 février 2024 1 844
21 oct. 2022 à 15:14

Bonjour,

Le plus simple serait d'inverse votre colonne F et E. 

RechercheV fonctionne de gauche à droite. Je m'explique:

La valeur cherchée doit TOUJOURS être dans la première colonne de la matrice.

Une fois la valeur trouvée, il affichera la xieme colonne ( avant dernier paramètre).

En inversant les deux colonne votre formule deviendra :

=RECHERCHEV(A2;$E$1:$F$30;2)

Et tout fonctionnera. Cette formule est bonne pour la case B2. Il vous suffira d'étendre votre formule après 


1
ALS35 Messages postés 1033 Date d'inscription jeudi 18 juillet 2019 Statut Membre Dernière intervention 9 janvier 2024 139
21 oct. 2022 à 15:31

Bonjour à tous,

Si tu ne peux inverser tes colonnes tu peux essayer :

=INDEX($E$1:$E$30;EQUIV(A1;$F$1:$F$30;0))

ou mieux si tu disposes de la fonction RECHERCHEX (selon ta version d'Excel) :

=RECHERCHEX(A1;$F$1:$F$30;$E$1:$E$30;"")

NB: @diablo13800, il ne faut pas oublier de mettre le dernier paramètre de RECHEREV à FAUX ou 0

=RECHERCHEV(A2;$E$1:$F$30;2;FAUX)

Cordialement

1
Sophie8959 Messages postés 4 Date d'inscription jeudi 20 octobre 2022 Statut Membre Dernière intervention 21 octobre 2022
21 oct. 2022 à 15:45

Bonjour à tous les deux,

Je vous remercie, ça marche impeccable en ayant fait un mélange de vos deux réponses. J'ai inversé mes deux colonnes et appliqué la formule suivante : 

=RECHERCHEV(A2;$E$1:$F$30;2;FAUX)

Merci beaucoup.

Cordialement

0