Trouver valeur d'une cellule en fonction d'une autre cellule

torxxl - 23 janv. 2022 à 11:38
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
- 23 janv. 2022 à 19:25
Bonjour,

J'ai dans mon premier onglet une colonne avec dans chaque cellule de celle-ci un menu déroulant qui affiche les articles qui se trouvent dans mon troisième onglet.

Je peux choisir dans le menu déroulant un article.

Dans le troisième onglet j'ai la liste des articles utilisés pour le menu déroulant et dans la colonne d'à coté le prix de l'article.

J'aimerais pouvoir afficher dans la première cellule le prix en fonction de l'article.

Je suis sur qu'Excel à une fonction mais je trouve pas.

D'avance merci pour votre aide.


Configuration: Windows / Firefox 96.0

5 réponses

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 256
23 janv. 2022 à 12:03
Bonjour
liste à traiter en feuil1, base de données en feuille 3 avec en A produit et en B prix
si article sélectionné en A2, en B2:
=SIERREUR(RECHERCHEV(feuil3!A:B;2;0);"")
crdlmnt
0
Bonjour,
Merci pour la réponse, je vais essayé de comprendre le fonctionnement.
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 256
23 janv. 2022 à 12:48
alors complétez la formule que j'ai raccourci par erreur (mal réveillé malgré l'heure tardive!

=SIERREUR(RECHERCHEV(A2;feuil3!A:B;2;0);"")

avec mes excuses
crdlmnt
0
torxxl
Messages postés
4
Date d'inscription
jeudi 16 février 2006
Statut
Membre
Dernière intervention
23 janvier 2022

23 janv. 2022 à 16:32
Bonjour,
J'ai fait un petit tableau pour testé est essayé de comprendre.
La première ligne fonctionne :
=SIERREUR(RECHERCHEV($D$13;$A$2:$A$11;$B$2:$B$11;0);"E")

Mais les suivantes me renvoie mon E et je ne vois pas pourquoi

=SIERREUR(RECHERCHEV($D$13;$A$2:$A$11;$B$2:$B$11;0);"E")


Encore un grand merci pour votre aide et votre patience

0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 256
Modifié le 23 janv. 2022 à 19:25
Bonjour
l'adresse de la plage de recherche n'est pas correcte et il manque le rang de la colonne à sortir
=SIERREUR(RECHERCHEV( $D$13;$A$2:$B$11;2;0);"E")
cette formule en D2 va vous renvoyer 3 (valeur de B sur la ligne jaque) et ceci quelque soit sa position dans la colonne D

0