Open office et la virgule

Résolu/Fermé
jeffrod
Messages postés
3
Date d'inscription
lundi 18 août 2003
Statut
Membre
Dernière intervention
18 août 2003
- 18 août 2003 à 13:46
 jo - 6 juin 2017 à 21:45
Salut à tous
Open office et le satané point du calc
Je cherche à remplacer le point du pavé numérique par la virgule
qui qui ait comment qu'on fait
J'ai déjà vu des questions de ce type sur le forum mais pas de réponse depuis il y a peut etre un erudit qu'a planché.
Merci d'avance

4 réponses

Bonjour jeffrod.

Pour ton problème de virgule, ouvre openoffice.
Dans " outils / options / paramètres linguistiques / langues " coche la case " identique à l'environnement liguistique ".
sous calc, le point deviendra une virgule.
94
Menu Outils - Options - Paramètres de langue - Onglet Langues
Touche séparateur de décimales - Identique à l'environnement linguistique
Spécifie que la touche séparateur de décimales définie dans votre système sera utilisée lorsque vous appuierez sur la touche correspondante du clavier numérique.
Si cette option est cochée, le caractère qui s'affiche après "Identique à l'environnement linguistique" est inséré lorsque vous appuyez sur la touche du clavier numérique. Si cette option n'est pas cochée, le caractère inséré est celui que fournit le logiciel de votre pilote de clavier.
avec cette config, quand j'appuie sur le point clavier numérique, j'ai une virgule
OOo 2.3.0
1
Non2
Messages postés
5093
Date d'inscription
mercredi 19 décembre 2007
Statut
Contributeur
Dernière intervention
15 juillet 2015
752
1 févr. 2008 à 15:32
Bonjour,

Oui, en effet. Le problème ici était d'avoir un point dans le traitement de texte et une virgule dans le tableur. Comme dans toutes les autres suites bureautiques.
Une solution qui fonctionne a été fournie aux posts 14, 20 et 21.
Merci quand même.
1
Yes , merci mamouth .

J'ai enfin trouver comment virrer cette *** de virgule alors que le bouton est un POINT !

;)
0
Merci Mammouth encore en 2009 ta bonne parole est écoutée et appréciée. Tu m'as enlevé une sacré épine du pieds ça commençait à sérieusement me gonfler cette virgule à la place du point.
0
christine33,
10 juin 2010 à 15:45
eh bien merci quand même pour les autres galériens. Ça m'a beaucoup aidé.
0
Voir Panneau de config
Paramètres régionaux
Symbol décimal : je pense qu'en remplaçant le point par la virgule, ton pavé numérique le prendra en compte.

Essaie !

(les autres paramètres sont indiqués)
1
mamidyo
Messages postés
12
Date d'inscription
dimanche 7 septembre 2008
Statut
Membre
Dernière intervention
6 mai 2009

6 mai 2009 à 20:37
j'ai trouvé la solution en paramétrant le clavier et ca marche
1
Non2
Messages postés
5093
Date d'inscription
mercredi 19 décembre 2007
Statut
Contributeur
Dernière intervention
15 juillet 2015
752
24 nov. 2008 à 15:51
Bonjour,

Même problème sur un autre OS : Outils > Options > Paramètres linguistiques > Langue > cocher ou décocher la case
"Touche séparateur de décimales / Identique à l'environnement linguistique..."

Toutefois, sous Linux, j'ai trouvé un petit script qui me permet de passer du point à la virgule par le système, hors de OOo. Je l'ai enregistré sous le nom PointVirgule.sh et l'ai rendu exécutable (clic droit sur le fichier > Droits d'accès > cocher "Est exécutable") pour passer sans problème du point à la virgule dans l'ensemble du système. En voici le contenu :

#!/bin/bash
val=`xmodmap -pke | grep "keycode 91 = KP_Delete KP_Decimal"`
echo $val
if [ -n "$val" ]
then
xmodmap -e 'keycode 91 = KP_Delete comma'
else
xmodmap -e 'keycode 91 = KP_Delete KP_Decimal'
fi


Un copié-colllé est plus facile que de recopier car il ontient des caractères spéciaux ( ` par exemple).
Une telle solution existe peut-être aussi sous Windows, mais je ne la connais pas. En espérant que ce soit utile à quelqu'un.
0