[Excel] Fichier client

Résolu/Fermé
Signaler
-
 tricia -
Bonjour,

Je voudrais créer un fichier excel avec une petite fonction je l'explique.
Dans une feuille je fais un tableau avec les colonnes suivantes (NOM CLIENT, ADRESSE, CPOSTAL, VILLE)
Dans une deuxieme feuille je veut avoir dans une premiere cellule un menu deroulant avec les noms de tout les clients rentrés dans la premiere feuille, ensuite en fonction du client choisie je veut que sur les cellule voisine s'affiche directement l'adresse cpostal et ville du client selectionner.

Merci

BENNY

10 réponses

Messages postés
55406
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
22 janvier 2022
17 225
1) Supposons que "NOM CLIENT" a été saisi dans la cellule A1 de la première feuille et qu'il y a 99 clients dans la liste :
2) Sélectionner la liste des données de NOM CLIENT (A2:A100) et lui donner le nom "Client".
3) Sélectionner la matrice A1:D100 et la nommer "Zone".
4) On passe à la feuille 2. Dans la cellule B2, faire :
Données/Validation des données/Options/Autoriser/Liste/Source/ et saisir Client, puis valider.
5) Dans la cellule C2, mettre la formule =RECHERCHEV(B2;Zone;2).
6) Dans la cellule D2, mettre la formule =RECHERCHEV(B2;Zone;3).
7) Dans la cellule E2, mettre la formule =RECHERCHEV(B2;Zone;4).

NB : à la place des instructions 5) à 7) on peut aussi saisir en C2 :
=RECHERCHEV(B2;Zone;2) & " " & RECHERCHEV(B2;Zone;3) & " " & RECHERCHEV(B2;Zone;4).
15
Salut

En plus :

Je suggère d'avoir deux cellules, qui seraient lu par le menu déroulant ; grâce une formule .

Soit :

Une cellule dans laquelle on tape les caractères que l'on veut qu'il y est .
Une cellule dans laquelle on tape les caractères que l'on ne souhaite pas qu'il y est .

***

Le menu déroulant, ne doit pas être mal conçu, si il y a énormément de nom .

Je demande, si 10 lignes de noms, visibles à la fois, seraient suffisantes ?

merci à tous pour de l'aide et ou votre aide . merci à tous .

à+
1
Messages postés
55406
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
22 janvier 2022
17 225
Anonyme, juste avant la question posée par benny, il y a une invitation "Posez votre question"
Tu devrais l'utiliser pour lancer ta propre discussion, au lieu de t'immiscer dans celle de benny sans sa permission.
0
Messages postés
1
Date d'inscription
mardi 15 avril 2008
Statut
Membre
Dernière intervention
15 avril 2008
1
message à raymond Pontier monsieur svp je cherche moi aussi a faire cette fonction mais le probleme c'est que comment quand je selectionne la matrice je lui donne un nom ou je mets le nom de la matrice car sa me donne toujours que le resultat est " erreur" merci davance
1
Messages postés
26404
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
6 184
Bonsoir
à Raymond surtout.... sans vouloir contredire, je pense que la formulation recommandée au mois de Février pour RECHERCHEV est incomplète.Il y manque le code de choix qui doit la terminer, à savoir après le N° de colonne, le code 0.
La formule est donc, à mon avis et sauf erreur:
=RECHERCHEV(B2;Zone;2;0) pour rechercher dans la deuxième colonne
=RECHERCHEV(B2;Zone;3;0) "" " troisième " "
Etc...
Vous pouvez si vous le souhaitez consulter quelques explications sur le sujet dans les messages "Vaucluse" des rubriques ci dessous:
http://www.commentcamarche.net/forum/affich 5930585 excel liste?dernier#dernier]
Message 5
http://www.commentcamarche.net/forum/affich 5928858 re tableau recapitulatif sur excel?dernier#dernier]
(message N°6 dans ce dernier sujet)
CRDLMNT

PS: quand vous avez des questions de ce genre, il est préférable d'ouvrir un nouveau sujet plutôt que de s'accrocher sur un ancien....qui risque de ne jamais être ouvert
0
Messages postés
55406
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
22 janvier 2022
17 225
Ne viens pas te mettre à la remorque d'une discussion déjà close, et ouverte par quelqu'un d'autre : c'est inefficace et c'est désinvolte.
Alors lance ta propre discussion : "Posez votre question", en dessous de la ligne "Rechercher". Profites-en pour formuler ton problème avec un peu plus de précision : Référence et contenu de tes différentes cellules.
0
Messages postés
1
Date d'inscription
samedi 1 mars 2014
Statut
Membre
Dernière intervention
1 mars 2014

Bonsoir,
Vaucluse j'ai fait la meme formule que vous mais j'ai pas de resultat. Dans les case C2, D2 et E2 jai ceci #N/A ,quelqu'un peut m'aider.
0
Messages postés
55406
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
22 janvier 2022
17 225
Oui ; on pourra t'aider dès qu'on aura ton fichier.
0
Messages postés
55406
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
22 janvier 2022
17 225
Benny, ta discussion a été fortement polluée par les intrusions de Anonyme et de kanarg.
Mais j'aimerais savoir si tu as pris en considération mon post 6, et où tu en es actuellement de ta réflexion.
-1
bonjour a tous !

Mon meilleur conseil à tous les nouveaux qui commencent avec Excel : prenez vous un jour ou deux pr faire une formation informatique sur Excel.
Je sais bien que vous êtes ici ponctuellement pour un petit pb à résoudre, mais Excel, comme tout autre logiciel, implique que l'on connaisse déja les "bases". Si on est pas à l'aise avec elles, alors rien ne sert de demander des formules ou autres... J'ai fait un jour de formation, et miracle ! Excel est "magique". Je n'y avais pas touché depuis des années, et j'ai parcouru des forums pour connaitre les formules, mais rien à faire, je n'y arrivait plus. Un jour de formation plus tard, je me fais des tableaux de bords, de gestion, statistiques et organigrammes presque les yeux fermés !
Voilà ! bon courage a tous !!!!!!!!!!
-1
Très bon conseil
0
Messages postés
101
Date d'inscription
mardi 9 octobre 2007
Statut
Membre
Dernière intervention
9 juin 2008
14
Personnellement je sais pas, je sais que le mieux serai une réponse directe mais bon,
sur se lien tu trouvera toutes les fonctions Excel dont tu pourai avoir besoin :
https://www.lecompagnon.info//excel/index.html

Sinon recherche des discutions similaires sur le forum programmation. Je sais que des sites officiels existent aussi pour Excel mais en anglais...

Bye.
-2
bonjour et merci pout votre reponse.
je vais essaier tout de suite et je vous tiendrais au courans...

bonne journee
-2
bonjour j'ai bien essaier ce que vous m'aviez conseiller
mais je constate que je n'arrive pas a faire une fiche cleint du style

nom du proprio:
adress:
tel:
personne a contacter en cas de probleme:
veto:

je suis completement perdue....
je ne suis absolument pas une pro de l'informatiqueXD
quelqu'un pourait me conseiller ou le donner d'autre solution que avec excel???
merci d'avance
et bonne journee
-2
Messages postés
55406
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
22 janvier 2022
17 225
kanarg, je ne t'ai rien conseillé du tout.
Ce n'est pas à toi que j'ai répondu au post 6, mais à benny.
Voila ce qui arrive quand on dort à plusieurs dans le même lit !
0
bonsoir , alor voila je travaille dans une pension pour animaux et a l'arivee de ceux ci les propiétaires doivent remplire une fiche d'indentification de l'animal.
seulement a partir de 1er juillet il faudra que meme si l'animal revien par la suite refaire la fiche...
j'aimerais savoir si avec excel on peu creer un fichier client comprenant les fiches deja remplies.

et egalment mettre un moyen de retourver facilement ces fiches par exemple en ayant un mode de recherche par nom.
merci d'avance
(ps: dsl pour les fautes d'ortho)
-3
Messages postés
55406
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
22 janvier 2022
17 225
knarg, juste avant la question posée par benny, il y a une invitation "Posez votre question"
Tu dois l'utiliser pour lancer ta propre discussion, au lieu de t'immiscer dans celle de quelqu'un d'autre.
0