Aditionner des "X" dans une colonne selon une variable ville

Résolu/Fermé
RIKO14 Messages postés 75 Date d'inscription jeudi 19 janvier 2017 Statut Membre Dernière intervention 14 juin 2024 - 2 août 2021 à 14:25
RIKO14 Messages postés 75 Date d'inscription jeudi 19 janvier 2017 Statut Membre Dernière intervention 14 juin 2024 - 3 août 2021 à 17:06
Bonjour,
Dans la cellule D138 je voudrais additionner des "X" de la colonne F (F5 : F127) mais selon la ville de la colonne B (B5 : B127).
https://www.cjoint.com/c/KHcmmCbEHmd
comment faire ?
Merci de votre aide.


Configuration: Windows / Chrome 92.0.4515.107

6 réponses

Mike-31 Messages postés 18318 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 26 avril 2024 5 082
Modifié le 2 août 2021 à 15:00
Bonjour,

Il ne faut pas confondre Execl et Open Office ou Libre Office qui sont des applications différentes

ta formule est

=NB.SI(F5:F127;"X")

par contre pour calculer le nombre de X par rapport à une ville saisie en A138, il est impératif que les noms de la colonne B et la saisie en A138 soient parfaitement identiques sans double points ou espace etc ...

=SOMMEPROD((F5:F127="X")*(B5:B127=A138)*(E5:E127<>""))

sur Libre office tu peux faire plus court =SOMMEPROD((F5:F127="X")*(B5:B127="CAEN"))
ou il faudra saisir dans la formule le nom de la ville en respectant également la mise en forme de celles colonne B
=SOMMEPROD((F5:F127="X")*(B5:B127="CAEN")*(E5:E127<>""))
0
RIKO14 Messages postés 75 Date d'inscription jeudi 19 janvier 2017 Statut Membre Dernière intervention 14 juin 2024 2
2 août 2021 à 15:34
J'ai réussi avec =SOMMEPROD((F5:F127="X")*(B5:B127="CAEN")) mais j'ai essayé en D139 pour =SOMMEPROD((G5:G127="X")*(B5:B127="CAEN")) et là j'ai 0.. je ne comprends pas..
0
yclik Messages postés 3619 Date d'inscription vendredi 25 juillet 2014 Statut Membre Dernière intervention 19 juin 2024 1 490
2 août 2021 à 16:57
Bonsoir
=SOMMEPROD((G5:G127="X")*(B5:B127="CAEN")) et là j'ai 0.
je ne reproduis pas sous open office

La formule pourrait être simplifiée pour la recopie
en B137 à B144 supprimer l'espace et les deux points ( :)
en D137
=SOMMEPROD(($F$5:$F$127="X")*($B$5:$B$127=$A137))

en E137
=SOMMEPROD(($G$5:$G$127="X")*($B$5:$B$127=$A137))

recopier ver le bas

le classeur
0
Mike-31 Messages postés 18318 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 26 avril 2024 5 082
Modifié le 2 août 2021 à 17:06
Re,
utilise la formule qui fonctionne
=SOMMEPROD(($F$5:$F$127="X")*($B$5:$B$127="CAEN"))

ou cette formule si tu réécris correcte en A138 le nom de ta ville CAEN
=SOMMEPROD(($F$5:F127="X")*($B$5:$B$127=$A138))

et tu verras que les formules fonctionnent et retourne 20 pour CAEN
et 4 pour BAYEUX en utilisant ton fichier
0
RIKO14 Messages postés 75 Date d'inscription jeudi 19 janvier 2017 Statut Membre Dernière intervention 14 juin 2024 2
3 août 2021 à 09:52
avec la formule : =SOMMEPROD(($F$5:$F$127="X")*($B$5:$B$127="VIRE")) ca marche nickel.

autre petit souci dans la colonne K je rentre des date de naissance au format 00/00/0000 et dans la colonne L j'utilise la =AUJOURDHUI()-K9 mais quand j'ai pas de date de naissance renseignée dans la colonne K il m'est indiqué le chiffre 21 dans la colonne L. Pourquoi et comment modifier pour qu'il n'y est pas de chiffre indiqué ?
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Mike-31 Messages postés 18318 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 26 avril 2024 5 082
Modifié le 3 août 2021 à 10:58
Re,

en L5 colle cette formule et incrémente la vers le bas

=SI(K5="";"";DATEDIF(K5;AUJOURDHUI();"y")) 


ou
=SI(K5="";"";ANNEE(AUJOURDHUI())-ANNEE(K5))
et formate la colonne L en format Standard

0
RIKO14 Messages postés 75 Date d'inscription jeudi 19 janvier 2017 Statut Membre Dernière intervention 14 juin 2024 2
3 août 2021 à 17:06
Merci Beaucoup !!
0