Synology, worpress, virtual host et ereur 500

Signaler
-
Messages postés
18569
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 juillet 2021
-
Bonjour,

J'ai actuellement un WordPress sur mon NAS Synology. J'ai effectué un VirtualHost sur le web station de Synology afin que lorsque que je n'ai pas a faire / WordPress a la fin de mon domaine pour y accéder.

Jusque l'a ca fonctionne, mais seulement pour la page principale et l'environnement administrateur. lorsque j'essais d'accéder a un autre pas j'ai un erreur 500.

de plus si j'essais de créer une autre page ou d'en modifier une depuis l'espace admin, j'ai une erreur JSON

Dites moi s'il vous faut des screen ou des précisions ?

Merci d'avance pour votre aide

1 réponse

Messages postés
18569
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 juillet 2021
4 305
Bonjour,

Tu as modifié la configuration serveur afin de disposer d'un VirtualHost dont le DocumentRoot pointe directement vers le dossier WordPress. Maintenant, il est également nécessaire de modifier ton site afin qu'il utilise la nouvelle adresse.

Il est nécessaire de
1) Mettre à jour l'URL de base dans la configuration de WordPress
2) Mettre à jour le fichier .htaccess

Actuellement, ton .htaccess contient probablement des règles de réécriture avec une URL qui inclue le dossier "WordPress", c'est probablement la cause de l'erreur 500.

Voir ici : https://wordpress.org/support/article/changing-the-site-url/

L'étape 1) permet de mettre à jour les URL générées dynamiquement par WordPress. Concernant les liens inscrits statiquement, il faut les mettre à jour à la main.
Bonjour,

Merci pour t'a réponse.

j'ai fais comme tu m'a dis.

rajouté le define dans mon wp config
et réécris le htaccess

mais j'obtiens une autre erreur :

Warning: require_once(/volume1/web/wordpress/wp-admin/includes/class-wp-site-health.php): failed to open stream: No such file or directory in /volume1/web/wordpress/wp-settings.php on line 528 Fatal error: require_once(): Failed opening required '/volume1/web/wordpress/wp-admin/includes/class-wp-site-health.php' (include_path='.:/usr/share/pear') in /volume1/web/wordpress/wp-settings.php on line 528
une erreur critique est survenue sur votre site.




ANCIEN HTACCESS

# BEGIN HTTPS Redirection Plugin
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{SERVER_PORT} !^443$
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
</IfModule>
# END HTTPS Redirection Plugin

# BEGIN WordPress
# Les directives (lignes) entre « BEGIN WordPress » et « END WordPress » sont générées
# dynamiquement, et doivent être modifiées uniquement via les filtres WordPress.
# Toute modification des directives situées entre ces marqueurs sera surchargée.
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /wordpress/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /wordpress/index.php [L]
</IfModule>

# END WordPress


Nouveau HTACCESS

# BEGIN HTTPS Redirection Plugin
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{SERVER_PORT} !^443$
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
</IfModule>
# END HTTPS Redirection Plugin

# BEGIN WordPress
# Les directives (lignes) entre « BEGIN WordPress » et « END WordPress » sont générées
# dynamiquement, et doivent être modifiées uniquement via les filtres WordPress.
# Toute modification des directives situées entre ces marqueurs sera surchargée.
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress


et dans le wp-config j'ai rajouté ces lignes :

define( 'WP_HOME', 'https://xxxxx.xx' );
define( 'WP_SITEURL', 'https://xxxx.xx' );


J'ai mal fais quelquechose ?
Messages postés
18569
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 juillet 2021
4 305 > Krymi
Je te conseille de supprimer ces deux "define" dans le fichier wp-config.php et plutôt modifier la valeur stockée en base de données : https://wordpress.org/support/article/changing-the-site-url/#changing-the-url-directly-in-the-database

Concernant l'erreur que tu obtiens, elle indique que WordPress tente de charger un fichier mais que celui-ci est manquant. Le fichier manquant est « /volume1/web/wordpress/wp-admin/includes/class-wp-site-health.php ». Cette erreur ne semble pas liée au changement de virtualhost ni au changement d'adresse.