#N/A dans une formule SI

Signaler
-
Messages postés
26102
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 juillet 2021
-
Bonjour à tous,

J'ai la formule ci-dessous qui fonctionne parfaitement, seulement lorsqu'elle ne trouve pas la donnée recherchée la cellule contenant la formule affiche #N/A. Je souhaiterais que la formule n'affiche rien si elle ne trouve pas la valeur recherchée (cas normal). Je ne suis pas arrivé avec la fonction ESTNA, si quelqu'un aurait une autre solution ou bien arrive avec la fonction ESTNA je serais très reconnaissant.

La formule est la suivante :

=SI(RECHERCHEV(D8;$A$44:$E$79;5;0)=AUJOURDHUI();SIERREUR(RECHERCHEV(D8;$A$44:$E$79;2;0);"");"")

Dites moi si je ne suis pas assez clair.
En vous remerciant par avance.

1 réponse

Messages postés
26102
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 juillet 2021
5 989
Bonjour
à ârtir d'Excel 2013, à rajouter en début et fin de formule (valable pour n'importe quelle formule):
=SIERREUR(SI(RECHERCHEV(D8;$A$44:$E$79;5;0)=AUJOURDHUI();SIERREUR(RECHERCHEV(D8;$A$44:$E$79;2;0);"");"");"")
crdlmnt