#N/A dans une formule SI

Fermé
AirSchaeff - 20 juil. 2021 à 19:19
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
- 20 juil. 2021 à 19:35
Bonjour à tous,

J'ai la formule ci-dessous qui fonctionne parfaitement, seulement lorsqu'elle ne trouve pas la donnée recherchée la cellule contenant la formule affiche #N/A. Je souhaiterais que la formule n'affiche rien si elle ne trouve pas la valeur recherchée (cas normal). Je ne suis pas arrivé avec la fonction ESTNA, si quelqu'un aurait une autre solution ou bien arrive avec la fonction ESTNA je serais très reconnaissant.

La formule est la suivante :

=SI(RECHERCHEV(D8;$A$44:$E$79;5;0)=AUJOURDHUI();SIERREUR(RECHERCHEV(D8;$A$44:$E$79;2;0);"");"")

Dites moi si je ne suis pas assez clair.
En vous remerciant par avance.

1 réponse

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 272
20 juil. 2021 à 19:35
Bonjour
à ârtir d'Excel 2013, à rajouter en début et fin de formule (valable pour n'importe quelle formule):
=SIERREUR(SI(RECHERCHEV(D8;$A$44:$E$79;5;0)=AUJOURDHUI();SIERREUR(RECHERCHEV(D8;$A$44:$E$79;2;0);"");"");"")
crdlmnt
2