Compte des cellules qui commencent par ";" [Résolu]

Signaler
-
 Nathalie -
Bonjour,

Je veux compter le nombre de cellules non vide, mais dont plusieurs commencent par un caractère spécial (soit ";" ou "&"). J'utilise la commande NB.SI(C8:T8;"><") , mais il ne compte pas les cellules qui commencent par les caractères spéciaux. Avez-vous une idée pour m'aider?

Merci beaucoup

Nathalie

8 réponses

Messages postés
54286
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
16 260
Bonjour.
=NBVAL(C8:T8)
devrait suffire ...
Messages postés
3334
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
23 juillet 2021
945
Bonjour Nathalie

La question est ambiguë !!!

•S'agit-il du nombre de toutes les cellules non vides ?

Dans ce cas la formule de Raymond ; que je salue ; est bonne.

•Ou s'agit-il de comptabiliser toutes les cellules contenant un caractère spécial en première position ?

Pour ce deuxième cas je fais cette proposition : formule à mettre sur la ligne en dessous, donc en C9 ; à incrémenter ensuite vers T9 ou Hors du tableau pour ne conserver que la cellule du total à l'intérieur du tableau.

=SI(C8="";"";SI(OU(GAUCHE(C8;1)=";";GAUCHE(C8;1)=":";GAUCHE(C8;1)="$";GAUCHE(C8;1)="&")=VRAI;1;""))


et faire ensuite le total de C9:T9

Dans cette formule je n'ai mis que 4 caractères à chercher, mettre autant de fois ;GAUCHE(C8;1)="signe" qu'il y a de signes à chercher ; à inclure avant la parenthèse fermante du OU() c'est à dire avant ")=VRAI"

Cordialement
Merci beaucoup messieurs pour vos réponses rapides. Je vois en effet, que ma question de départ manquait de précision.

En fait, je veux compter le nombre de cellules non vides, mais elles contiennent toutes le résultat de formules de concaténation qui peut être "" ou "a;b;c;d" ou ";;c;d". Si j'ai ces trois exemples, j'aimerais pouvoir compter ces cellules et avoir 2 comme réponse (soit "a;b;c;d" et ";;c;d") . NBVAL me donne 3 (il compte aussi la cellule qui contient "") et NB.SI(A1:A3;"><") me donne 1 (il ne compte pas la cellule qui possède ";;c;d"). Je ne sais pas d'avance combien de ";" je vais avoir en début de chaine de caractère dans mes cellules.

Merci encore!

Nathalie
Messages postés
10185
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
22 juillet 2021
1 165
Bonjour,
Juste au passage pouvez-vous indiquer la formule qui se trouve dans la cellule concernée?
Se serait plus profitable si vous mettez le fichier à disposition..! Vous indiquez aussi le résultat que vous voulez obtenir pour la/les cellules concernées (2 ou 3 exemples suffises.

Salutations.
Le Pingou
Bonjour à tous, voici plus de précision.

Dans la formule de la colonne E, je concatène le contenu des colonnes A, B, C et D. En plus, j'ai ajouté un si toutes les cellules sont vides, mettre "" (qui donne une cellule "vide" en E3. Je n'ai pas mis la formule au long ici pour rester simple).

A B C D E =concatener(A1;";";B1;";";C1;";";D1)
1 rouge bleu radis dé rouge;bleu;radis;dé
2 vert ;vert;;
3
4 jus dé ;;jus;dé


Je veux maintenant savoir le nombre de cellules dans la colonne E qui sont non vides: ici, je voudrais avoir 3 comme réponse (soit les cellules E1, E2, et E4). NBVAL donne 4 (il additionne la cellule E3) et NB.SI(E:E;"><") me donne 1 (il n'additionne pas les cellules E2 ni E4, car elles commencent par un ";"). Je ne sais pas d'avance combien de ";" j'aurai en début de champ, car je contatène plusieurs cellules (plus que 4 en réalité).

Merci beaucoup pour votre aide!

Nathalie
Messages postés
3334
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
23 juillet 2021
945
On peut partir sur un autre genre de concaténation ; en E1

=SIERREUR(CNUM(SI(A1<>"";1;"")&SI(B1<>"";2;"")&SI(C1<>"";3;"")&SI(D1<>"";4;""));"")


ce qui va donner une suite de nombres ou rien si les quatre cellules sont vides ; formule à incrémenter vers E4

et pour avoir le total de cellules non vides de la colonne E

=NB.SI(E1:E4;">0")


Cordialement
Messages postés
24138
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 juillet 2021
6 842
Bonjour,

Ah oui, c'est bizarre que =NB.SI(E:E;"><") ne compte pas celles commençant par un ;

Sinon, ça revient à compter celles qui ont un ;
=NB.SI(E2:E5;"*;*")


Si tu as plusieurs caractères, soit tu les comptes individuellement en faisant la somme, ou si tu en as trop à sommer :
=SOMMEPROD(--(NBCAR(E2:E5)>0))

eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Bonjour à tous,

Les solutions d'Éric et PapyLuc fonctionnent très bien. Vous avez résolu mon problème et j'en suis très reconnaissante! Un gros merci et une très belle fin de semaine à vous!

Nathalie