Extraction de 1 ou 2 chiffres [Résolu]

Signaler
Messages postés
574
Date d'inscription
mardi 5 août 2008
Statut
Membre
Dernière intervention
18 juin 2021
-
Messages postés
574
Date d'inscription
mardi 5 août 2008
Statut
Membre
Dernière intervention
18 juin 2021
-
Bonjour à tous,

Dans la colonne A j’ai des nombres pouvant avoir 11 ou 12 chiffres.
J’ai besoin d’extraire, dans la colonne C, le premier ou les deux premiers chiffres selon qu’il y est 11 ou 12 chiffres dans la colonne A.
Si j’ai 11 chiffres, je prends que le premier.
Si j’ai 12 chiffres, je prends les deux premiers.
J’ai la formule ci-dessous, mais elle ne fonctionne pas, car je n’ai que le premier chiffre du nombre concerné.
=SI(NBCAR($A277=11);GAUCHE($A277;1);SI(NBCAR($A277>11);GAUCHE($A277;2)))


Pouvez-vous m’aider?
D’avance Merci.
Mistral

5 réponses

Messages postés
2477
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
18 juin 2021
984
Bonjour,
Si ce sont bien des nombres: =ENT($A2/100000000000)
Messages postés
2514
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
28 juillet 2021
1 154
Bonjour
il faudrait
=SI(NBCAR($A277)=11;GAUCHE($A277;1);SI(NBCAR($A277)>11;GAUCHE($A277;2)))

) mal positionnée il faut fermer la fonction avant comparer le résultat
SI(NBCAR($A277)=11
Messages postés
3344
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
29 juillet 2021
946
Bonjour,

Une erreur dans le NBCAR, la valeur limite après la parenthèse fermante

=SI(NBCAR($A278)=11;GAUCHE($A278;1);SI(NBCAR($A278)>11;GAUCHE($A278;2);""))


Cordialement
Messages postés
26120
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 juillet 2021
5 998
Bonjour
essayez en écrivant correctement la formule car dans ce cas elle fonctionne chez moi:
=SI(NBCAR($A277)=11;GAUCHE($A277;1);SI(NBCAR($A277)>11;GAUCHE($A277;2)))
avec la parenthèse derrière le CAR et pas derrière le =11 ou =12
et peut être plus simplement:
=SI(NBCAR($A277)=11);GAUCHE($A277;1);GAUCHE($A277;2)))
ou encore:
=GAUCHE($A277;NBCAR($A277)-10)
crdlmnt
Messages postés
574
Date d'inscription
mardi 5 août 2008
Statut
Membre
Dernière intervention
18 juin 2021
3
Suis-je Bête !!!

Merci à tous.