Numérotation automatique des résultats excel [Résolu]

Signaler
-
 SZak -
Bonjour,

je vais vous expliquer mon problème avec un exemple ça sera plus simple :

Dans la colonne A j'ai une liste déroulante avec les mots (au hasard) Voiture, Vélo, Roller, Camion.
Quand je choisis "Voiture" dans la cellule A1, j'aimerai que dans la cellule B1 se mette automatiquement "Voiture n°1"... Jusque là rien de compliqué j'ai déjà réussi...
Le truc c'est que j'aimerai que ça se fasse automatiquement pour tous les mots. Par exemple si j'ai "Voiture" dans A1, "Camion" dans A2 et "voiture" dans A3, j'aimerai que la formule reconnaisse que Voiture est dans A1 et que du coup elle mette automatiquement Voiture n°2 dans A3... Vous voyez ce que je veux dire ?
En gros que la formule numérote automatique la voiture, le camion, vélo etc de façon indépendante dans la même colonne...

merci d'avance pour votre aide

5 réponses

Messages postés
10048
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
9 juin 2021
1 148
Bonjour,
Je vous propose d'essayer avec la formule ci dessous en "B1" et la tirer vers le bas
=A1&" n° "& NB.SI($A$1:$A1;A1) 
Salut le pingou, ta formule fonctionne merci ! mais est-ce que tu saurais comment faire pour que dans les cases vides il n'y ai pas le "n°" !
Merci d'avance
Messages postés
9848
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
9 juin 2021
2 128
Bonjour

Pour compléter la proposition de Le Pingou (salut amical au passage), pour que la numérotation se fasse à la saisie, ce sera avec une petite macro
https://www.cjoint.com/c/KFiognwRyLB

Cdlmnt
Messages postés
10048
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
9 juin 2021
1 148
Merci, très intéressant la petite procédure
Amicales salutations
Messages postés
9848
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
9 juin 2021
2 128
je vais me permettre de compléter la proposition de Le Pingou

=SI(A1="";"";A1&" n° "& NB.SI($A$1:$A1;A1) )

Bonne soirée
Merci bcp l'équipe c'était rapide et clair ! :)
Messages postés
9848
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
9 juin 2021
2 128
De rien

Si c'est fini, peux tu mettre le sujet à résolu (en haut dans ton premier message)
RQ. As tu testé la solution macro ?
Je reviens vers toi mon sauveur, j'ai 2 autres petits soucis ^^
Est-il possible de faire une numérotation de 2 listes différentes dans la même colonne ? J'aimerai intégrer une autre liste mais présente dans une autre colonne

et la 2e question : est-il possible de réinitialiser la numérotation à partir d'une certaine ligne mais avec la même liste ? par ex que la numérotation de la voiture repasse à n°1 à partir de la ligne 10 sans que ça change la numérotation au dessus

Merci d'avance si tu me réponds.
C'est fait !
Non j'ai pas testé je m'y connais 0 en macro j'ai pas voulu tout foutre en l'air :)