Comparer deux fichiers Excel et résultat dans un des deux fichiers [Résolu]

Signaler
Messages postés
4
Date d'inscription
mercredi 2 juin 2021
Statut
Membre
Dernière intervention
8 juin 2021
-
Messages postés
4
Date d'inscription
mercredi 2 juin 2021
Statut
Membre
Dernière intervention
8 juin 2021
-
Bonjour,
J'ai deux fichiers Excel ayant comme champ identique le numéro d'employé.
Fichier A = Numéro d'employé et +
Fichier B= Numéro d'employé et numéro de service et +
Besoin
Si numéro employé est identique fichier A et B inscrire le numéro de service du fichier B dans le fichier A
DANS UNE MACRO S.V.P

Merci beaucoup!

2 réponses

Messages postés
5563
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
16 juin 2021
619
Bonjour

Avec la fonction RECHERCHEV(...)

Exemple :

=SIERREUR(RECHERCHEV(A3;[ClasseurB.xlsx]Feuil1!$A$1:$F$20;5;0);"")
Colonne A = numéro employé
Classeur B
;[ClasseurB.xlsx]Feuil1!$A$1:$F$20;5;0)
A1: F20 champ de recherche sur classeur B
colonne A = numéro employé
L'information N° service est en colonne E (5) dans mon exemple


Messages postés
4
Date d'inscription
mercredi 2 juin 2021
Statut
Membre
Dernière intervention
8 juin 2021

Merci Philou tout est OK!
Messages postés
4
Date d'inscription
mercredi 2 juin 2021
Statut
Membre
Dernière intervention
8 juin 2021

Merci mais j'ai des champs vides.
Je revalide la formule!