Extraire valeurs uniques [Résolu]

Signaler
Messages postés
59
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
22 juin 2021
-
Messages postés
59
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
22 juin 2021
-
Bonjour,

Je souhaiterais obtenir la formule qui permet d’afficher les valeurs de la colonne 3.

01/01/2021 PIERRE 1
01/01/2021 PAUL 0
01/01/2021 JACQUES 0
02/02/2021 PIERRE 1
02/02/2021 PAUL 0
02/02/2021 JACQUES 0
03/03/2021 PIERRE 1
03/03/2021 PAUL 0
03/03/2021 JACQUES 0
01/01/2021 PIOTR 0

Ce que je veux c’est avoir le nombre de valeur unique de la colonne 1.
Il y a ici 10 lignes (mais le tableau que j’envisage pourrait en avoir plusieurs centaines…)
Il n’y a que 3 valeurs différentes : 1er janvier, 2 février, 3 mars.
A la ligne 10, le premier janvier revient mais il n’est pas compté puisqu’il apparaît déjà.

Merci d’avance !

7 réponses

Messages postés
2364
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
21 juin 2021
411
Messages postés
9881
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
22 juin 2021
2 141
Bonjour à tous les deux

Ce que je veux c’est avoir le nombre de valeur unique de la colonne 1.
=SOMME(SI(A2:A11<>"";1/NB.SI(A2:A11;A2:A11)))
formule matricielle à valider avec Ctrl+Maj+Entrée (elle se mettra alors entre deux accolades

Cdlmnt
Messages postés
784
Date d'inscription
dimanche 15 novembre 2015
Statut
Membre
Dernière intervention
17 juin 2021
139
Bonsoir,

En considérant que dans la colonne A il n'y à que les dates alors

=SOMMEPROD(1/NB.SI(A1:A10;A1:A10))


Slts
Messages postés
784
Date d'inscription
dimanche 15 novembre 2015
Statut
Membre
Dernière intervention
17 juin 2021
139
???????????
Messages postés
9881
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
22 juin 2021
2 141
Ah !!!

En D2
=SI(OU(A2=A1;NB.SI(A$2:A2;A2)>1);0;1)
à tirer vers le bas
https://mon-partage.fr/f/3kqU5YZF/

Cdlmnt
Messages postés
59
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
22 juin 2021

Bonjour,

merci pour vos propositions :

Voici les résultats que j'obtiens

ccm81 The_boss_68 The_boss_68
sans ctrl/maj/entr avec vtrl/maj/entr

01/01/2021 PIERRE 3 0,25 3
01/01/2021 PAUL 3 0,25 3
01/01/2021 JACQUES 3 0,25 3
02/02/2021 PIERRE 3 0,33 3
02/02/2021 PAUL 3 0,33 3
02/02/2021 JACQUES 3 0,33 3
03/03/2021 PIERRE 3 0,33 3
03/03/2021 PAUL 3 0,33 3
03/03/2021 JACQUES 3 0,33 3
01/01/2021 PIERRE 3 0,25 3

Cordialement,
Messages postés
59
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
22 juin 2021

1re colonne de résultats = proposition de ccm81
2ème colonne : celle de the boss 68 sans formule matricielle
3ème colonne : celle de the boss 68 avec formule matricielle
Messages postés
59
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
22 juin 2021

Super!

Merci beaucoup!
Messages postés
9881
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
22 juin 2021
2 141
De rien,

Mais
je souhaiterais obtenir la formule qui permet d’afficher les valeurs de la colonne 3.
ce que tu souhaitais (réponse post 7)
Ce que je veux c’est avoir le nombre de valeur unique de la colonne 1.
ce que tu voulais (réponse post 2)
Il a fallu choisir à pile ou face pour la première réponse
Et je ne parle pas du titre
Extraire valeurs uniques
(réponse post 1)

Bon après midi
Messages postés
59
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
22 juin 2021
>
Messages postés
9881
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
22 juin 2021

Bonjour,

Je serai dorénavant plus attentif à la clarté de mes questions et à la précision de mes demandes.

En attendant, je vous remercie pour l'aide que vous m'avez apportée.