Formule SI selon format de cellule devise [Résolu]

Signaler
Messages postés
10
Date d'inscription
mercredi 5 mai 2021
Statut
Membre
Dernière intervention
28 mai 2021
-
Messages postés
24102
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 juin 2021
-
Bonjour,

dans une feuille de calcul, je saisie des montants (colonne A), certains en Euro et d'autres en Dollars que je différencie grâce aux format de cellule.

je souhaite faire apparaitre dans une autre cellule (colonne B) uniquement les montants en dollars.
j'y arrive si je saisie le symbole $ mais dans ce cas je ne peux pas additionner les montants...

merci de votre aide.

1 réponse

Messages postés
24102
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 juin 2021
6 802
Bonjour,

récupère le format utilisé pour $ avec :
=CELLULE("format";A2)

Chez moi c'est "P2" ce qui donne :
=SI(CELLULE("format";A2)="P2";A2;"")

eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Messages postés
10
Date d'inscription
mercredi 5 mai 2021
Statut
Membre
Dernière intervention
28 mai 2021

merci Eric mais j'ai A2 qui se met partout...
comment je peux récupérer le format utilisé?
- pour précision j'utilise en fait Format Nombre Comptabilité
Messages postés
24102
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 juin 2021
6 802 >
Messages postés
10
Date d'inscription
mercredi 5 mai 2021
Statut
Membre
Dernière intervention
28 mai 2021

Exemple : https://www.cjoint.com/doc/21_05/KECk4ZXRSND_Classeur1.xlsx
Sinon dépose un fichier
eric
Messages postés
10
Date d'inscription
mercredi 5 mai 2021
Statut
Membre
Dernière intervention
28 mai 2021
>
Messages postés
24102
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 juin 2021

sur mon fichier même ta formule pour trouver le format ne fonctionne pas :(

https://www.cjoint.com/c/KECmriZodUv
Messages postés
10
Date d'inscription
mercredi 5 mai 2021
Statut
Membre
Dernière intervention
28 mai 2021
>
Messages postés
10
Date d'inscription
mercredi 5 mai 2021
Statut
Membre
Dernière intervention
28 mai 2021

J'ai trouvé mon souci, le format de la cellule doit être en Monétaire et pas en Standard...
ça alourdi un peu visuellement car ça met € mais au moins ça fonctionne.
merci Eric.
Messages postés
24102
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 juin 2021
6 802 >
Messages postés
10
Date d'inscription
mercredi 5 mai 2021
Statut
Membre
Dernière intervention
28 mai 2021

Si tu les saisis en texte c'est un traitement de chaine qu'il faut faire et convertir le résultat en numérique.
Ex avec "5 $" :
=SI(DROITE(A2;2)=" $";--GAUCHE(A2;NBCAR(A2)-2);"")

Par contre en texte en A, tu ne peux faire aucune opération dessus directement.
eric