SI.CONDITIONS

Signaler
Messages postés
1
Date d'inscription
lundi 17 mai 2021
Statut
Membre
Dernière intervention
17 mai 2021
-
Messages postés
706
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
24 juillet 2021
-
Bonjour,

j'ai créé une formule SI avec 4 cas de figures et à chaque fois 2 conditions pour chaque cas de figure.
Donc, il y a 4 possibilités et chacune de ces possibilités doit remplir 2 critères.

Voici ma formule :

=SI.CONDITIONS(ET(M5>B1;ESTVIDE(N5));NB.JOURS.OUVRES(M5;B2);(ET(M5<B1;N5<B2));NB.JOURS.OUVRES(B1;N5);(ET(M5<B1;ESTVIDE(N5));NB.JOURS.OUVRES(B1;B2);(ET(M5>B1;N5<B2);NB.JOURS.OUVRES(M5;N5)

Cependant, elle ne fonctionne pas et je ne comprends pas pourquoi :-(

Pouvez-vous m'aider svp ?

Merci beaucoup !!
Bien à vous
Laetitia.

2 réponses

Messages postés
2667
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
30 juillet 2021
1 600
Bonjour,

Le mieux est de passé par des Si imbriquées selon moi:
Exemple:
=SI(ESTVIDE(N5);si(M5>B1;NB.JOURS.OUVRES(M5;B2);NB.JOURS.OUVRES(B1;B2));SI(N5<B2;SI(M5<B1;NB.JOURS.OUVRES(B1;N5);NB.JOURS.OUVRES(M5;N5));"N5 est supérieur a B2"))
Messages postés
706
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
24 juillet 2021
53
Bonjour à tous,

Des parenthèses manquantes ou en trop :
=SI.CONDITIONS(ET(M5>B1;ESTVIDE(N5));NB.JOURS.OUVRES(M5;B2);ET(M5<B1;N5<B2);NB.JOURS.OUVRES(B1;N5);ET(M5<B1;ESTVIDE(N5));NB.JOURS.OUVRES(B1;B2);ET(M5>B1;N5<B2);NB.JOURS.OUVRES(M5;N5))


Cordialement