Port 25 bloquer par mon FAI

Signaler
Messages postés
184
Date d'inscription
vendredi 11 octobre 2013
Statut
Membre
Dernière intervention
29 avril 2021
-
Messages postés
10505
Date d'inscription
jeudi 30 juin 2005
Statut
Contributeur
Dernière intervention
29 avril 2021
-
Salut,

Je voudrais héberger mon serveur de courriel chez moi mais mon FAI bloque le port 25, j'ai lu que on peut utiliser le port 587 mais je comprend pas comment. Il est présentement chez mes parents, tout fonctionne mais ils n’ont pas de groupe électrogènes, moi oui. C'est la raison du transfère. :-)

Donc, J'ai "dé-commenter" la ligne:

submission inet n       -       y       -       -       smtpd


dans
/etc/postfix/master.cf
, le port semble ouvert mais je ne reçois rien et quand j’envoi un mail, il ne se rend pas.



Est-ce que c'est possible ou pas d'utiliser le port 587?

Merci pour l'aide.

Guillaume

7 réponses

Messages postés
184
Date d'inscription
vendredi 11 octobre 2013
Statut
Membre
Dernière intervention
29 avril 2021
1
Quand j’envoie des mails à moi même ou à d'autres compte, même domaine ou pas ça fonctionne, c'est seulement quand j’envoie des mails vers d'autre serveurs et quand d'autre serveur essais d'envoyer des mails vers le miens.

Le log montre beaucoup de message du genre: Apr 28 00:38:27 mail-dc postfix/smtp[91573]: connect to outlook-com.olc.protection.outlook.com[104.47.58.33]:25: Connection timed out

Merci de m'aider.
Messages postés
10505
Date d'inscription
jeudi 30 juin 2005
Statut
Contributeur
Dernière intervention
29 avril 2021
7 134
Bonjour,

C’est bloqué car le port 25 n’est pas sécurisé et vous ne pourrez pas le débloquer
Lire cet article https://www.powermail.fr/tech/le-port-25-pourquoi-est-il-bloque/

Cdlt.
Messages postés
184
Date d'inscription
vendredi 11 octobre 2013
Statut
Membre
Dernière intervention
29 avril 2021
1
Salut,

Mais le port 587 n’est pas bloquer, est-t’il possible de faire fonctionner mon serveur sur ce port? C’est ça que j’essai d’accomplir. Voulez-vous que je poste contenu du fichier master.cf du serveur?

Merci

Guillaume
Messages postés
10505
Date d'inscription
jeudi 30 juin 2005
Statut
Contributeur
Dernière intervention
29 avril 2021
7 134
Je suppose que vous faites référence à ceci https://docs.switzernet.com/public/100608-postfix-reconf/ pour utiliser le port 587.
Mais avez vous fait les redirections nécessaire pour communiquer vers l’extérieur et pour recevoir de l’extérieur ?
Car votre serveur utilise une ip locale je suppose...
Messages postés
184
Date d'inscription
vendredi 11 octobre 2013
Statut
Membre
Dernière intervention
29 avril 2021
1
Bonjour,

Oui effectivement je fait référence a ce que il est expliquer dans le liens que vous avez poster. C'est exactement ce que j’essaie d'accomplir.

Les ports 143 et 587 sont pourtant rediriger vers le serveur à l'adresse 192.168.2.119 .

Mais la communication entre deux serveurs et t'elle possibles sur le port 587?

Merci,

Guillaume
Messages postés
10505
Date d'inscription
jeudi 30 juin 2005
Statut
Contributeur
Dernière intervention
29 avril 2021
7 134
Bonjour,

Quand vous dites "quand j’envoie des mails vers d'autre serveurs",

Vers quels serveurs voulez-vous envoyer ?
Avez vous fait les enregistrements DNS nécessaire chez le fournisseur de votre domaine ?

Plus d’infos ici https://artisan.karma-lab.net/propre-serveur-courrier-postfix

Cdlt.

Messages postés
184
Date d'inscription
vendredi 11 octobre 2013
Statut
Membre
Dernière intervention
29 avril 2021
1
Salut,

Par "quand j’envoie des mails vers d'autre serveurs" je veux dire que postfix sur mon serveur et le postfix chez Outlook, GMail et autre peuvent échanger des mails sur le port 587 car 25 est bloqué par mon FAI.

Pour les enregistrements DNS, tous semble correct. Je pense que c'est juste qu'il faut utiliser un port autre que 25.

Merci,

Guillaume
Messages postés
10505
Date d'inscription
jeudi 30 juin 2005
Statut
Contributeur
Dernière intervention
29 avril 2021
7 134
Voire cette aide https://admin-serv.net/blog/469/postfix-contourner-le-blocage-du-port-25-en-utilisant-un-autre-port/ plus détaillée afin d’utiliser le port 587 avec postfix.

Cdlt.
Messages postés
184
Date d'inscription
vendredi 11 octobre 2013
Statut
Membre
Dernière intervention
29 avril 2021
1
J'ai effectuer ce qui étais suggérer dans votre lien, le port 587 est ouvert mais quand j'envoie un mail de teste j'ai toujours ça dans le log: Apr 29 06:58:09 mail-dc postfix/smtp[457249]: 5CB7F140C55: to=<testing@yopmail.com>, relay=none, delay=30, delays=0.11/0.05/30/0, dsn=4.4.1, status=deferred (connect to smtp.yopmail.com[87.98.164.155]:25: Connection timed out)

On dirais que ça utilise toujours le port 25.

Merci,

Guillaume
Messages postés
10505
Date d'inscription
jeudi 30 juin 2005
Statut
Contributeur
Dernière intervention
29 avril 2021
7 134 >
Messages postés
184
Date d'inscription
vendredi 11 octobre 2013
Statut
Membre
Dernière intervention
29 avril 2021

Votre fichier master.cf est bien configuré ainsi https://ixnfo.com/en/how-to-enable-port-587-in-postfix.html

submission inet n - n - - smtpd
-o syslog_name=postfix/submission
-o smtpd_tls_security_level=encrypt
-o smtpd_sasl_auth_enable=yes
-o smtpd_client_restrictions=permit_sasl_authenticated,reject

Cdlt