Formule numéro de semaine iso

Résolu/Fermé
Planning - 22 avril 2021 à 20:14
 planning - 23 avril 2021 à 12:18
Bonjour,


Il y a un bug excel avec la formule numéro de semaine ISO. Elle renvoie semaine 52 lorsqu'elle pointe sur une cellule vide .
Avez vous une solution ?


Configuration: Android / Chrome 90.0.4430.82
A voir également:

4 réponses

jee pee Messages postés 36390 Date d'inscription mercredi 2 mai 2007 Statut Modérateur Dernière intervention 29 novembre 2022 8 842
Modifié le 22 avril 2021 à 20:54
Bonjour,

=SI(A1<>"";formule;"") 


0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 283
22 avril 2021 à 20:59
Bonsoir
Excel considère une cellule vide ou égale à 0 comme le 0 janvier 1900, donne un mois de janvier avec MOIS et un jour de semaine le samedi en iso avec JOURSEM
Alors pour le N° de semaine, c'est du même type!
Ecrivez:
=Si(cell="";"";NO.SEMAINE.ISO(cell))
crdlmnty
0
Bonjour

Merci pour votre réponse mais cela ne règle pas mon problème final.

Je vous donne plus de détails. Je dois construire un planning automatisé avec une mise en forme conditionnelle qui affiche dans le planning les périodes de tension dispo produit et les périodes de rupture.
J'ai rédigé ma formule qui fonctionne très bien lorsque j'utilise la fonction n°de semaine. Par contre il y a un décalage avec notre calendrier puisque la formule se base sur le calendrier américain. Du coup, j'utilise la formule n° de semaine ISO mais la mise en forme ne fonctionne plus.
0
jee pee Messages postés 36390 Date d'inscription mercredi 2 mai 2007 Statut Modérateur Dernière intervention 29 novembre 2022 8 842
23 avril 2021 à 10:53
tu introduit un autre élément la MFC où les formules peuvent être différentes dans leur formulation
donc donnes un fichier exemple en détaillant ta demande avec précision (mettre le fichier sur un site comme cjoint.fr et mettre le lien sur le forum)
0
Bonjour

Voici le lien pour accéder à mon fichier.

Merci beaucoup pour votre aide.

https://www.cjoint.com/c/KDxi3BEwAWZ
0
jee pee Messages postés 36390 Date d'inscription mercredi 2 mai 2007 Statut Modérateur Dernière intervention 29 novembre 2022 8 842
23 avril 2021 à 12:10
si le soucis c'est le numéro zéro, c'est que dans les formules il ne faut pas mettre "0", qui est une chaine texte, mais 0 qui est un nombre
0
planning > jee pee Messages postés 36390 Date d'inscription mercredi 2 mai 2007 Statut Modérateur Dernière intervention 29 novembre 2022
23 avril 2021 à 12:18
Merci beaucoup. ça fonctionne bien.
0