Formule numéro de semaine iso [Résolu]

Signaler
-
 planning -
Bonjour,


Il y a un bug excel avec la formule numéro de semaine ISO. Elle renvoie semaine 52 lorsqu'elle pointe sur une cellule vide .
Avez vous une solution ?


Configuration: Android / Chrome 90.0.4430.82

4 réponses

Messages postés
31853
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
14 mai 2021
7 652
Bonjour,

=SI(A1<>"";formule;"") 


Messages postés
26015
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
11 mai 2021
5 920
Bonsoir
Excel considère une cellule vide ou égale à 0 comme le 0 janvier 1900, donne un mois de janvier avec MOIS et un jour de semaine le samedi en iso avec JOURSEM
Alors pour le N° de semaine, c'est du même type!
Ecrivez:
=Si(cell="";"";NO.SEMAINE.ISO(cell))
crdlmnty
Bonjour

Merci pour votre réponse mais cela ne règle pas mon problème final.

Je vous donne plus de détails. Je dois construire un planning automatisé avec une mise en forme conditionnelle qui affiche dans le planning les périodes de tension dispo produit et les périodes de rupture.
J'ai rédigé ma formule qui fonctionne très bien lorsque j'utilise la fonction n°de semaine. Par contre il y a un décalage avec notre calendrier puisque la formule se base sur le calendrier américain. Du coup, j'utilise la formule n° de semaine ISO mais la mise en forme ne fonctionne plus.
Messages postés
31853
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
14 mai 2021
7 652
tu introduit un autre élément la MFC où les formules peuvent être différentes dans leur formulation
donc donnes un fichier exemple en détaillant ta demande avec précision (mettre le fichier sur un site comme cjoint.fr et mettre le lien sur le forum)
Bonjour

Voici le lien pour accéder à mon fichier.

Merci beaucoup pour votre aide.

https://www.cjoint.com/c/KDxi3BEwAWZ
Messages postés
31853
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
14 mai 2021
7 652
si le soucis c'est le numéro zéro, c'est que dans les formules il ne faut pas mettre "0", qui est une chaine texte, mais 0 qui est un nombre
>
Messages postés
31853
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
14 mai 2021

Merci beaucoup. ça fonctionne bien.