Aide ppur formule

Fermé
NIKIVEVE - 19 avril 2021 à 18:00
 Nikiveve - 20 avril 2021 à 12:11
Bonjour,

Je ne m'en sors pas avec une formule ci dessous mon type de tableau:

A1 B1
IDF/AME/AQ/FO/078 Formulaire
IDF/IH/FI/096 Fiche
IDF/PO/PW/PR/043 Procedure
IDF/MI/MO/034 Mode operatoore

J'aimerais qu'excel trouve les 2 dernieres lettres de la cellule A1 soit "Fo" pour la 1ère ligner et que dans la cellule B1 il écrive "Formulaire"
Idem pour la 2ème ligne "FI" egal "fiche" dans B1 et ceci sur plus de 500 lignes.

Je suis perdue, je cherche depuis 2h avec la fonction SI ou Cheche voir les 2 mais je n'y arrive pas.

Pouvez-vous m'aider ?

Merci d'avance

Configuration: Android / Chrome 90.0.4430.66

4 réponses

yclik Messages postés 3027 Date d'inscription vendredi 25 juillet 2014 Statut Membre Dernière intervention 27 novembre 2022 1 365
19 avril 2021 à 18:29
Bonsoir
A tester
=SI(ESTERREUR(TROUVE("FO";A1));"";"FO")&SI(ESTERREUR(TROUVE("FI";A1));"";"Fiche")&SI(ESTERREUR(TROUVE("PR";A1));"";"Procédure")&SI(ESTERREUR(TROUVE("MO";A1));"";"Mode opératoire")
2
Bonsoir,

Je vais tester demain. Je vous dirais si ça marche

Merci!!
Cdlt
0
Merci ça marche!!
0
via55 Messages postés 13965 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 27 novembre 2022 2 520
19 avril 2021 à 18:22
Bonjour

Un exemple à adapter
https://mon-partage.fr/f/eMX2azLI/

Cdlmnt
Via
1
Bonsoir,

Je vais voir si ça marche
Merci!!!
Cdlt
0
PapyLuc51 Messages postés 3794 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 28 novembre 2022 1 195
Modifié le 19 avril 2021 à 18:23
Bonjour

Il n'y a que ces 4 textes à renvoyer (formulaire, Fiche, Procédure et Mode opératoire) ou il y en a plus ??
Les deux lettres à extraire sont-elles toujours en 5ème et 6ème position par rapport à la droite de la chaîne ??

Cordialement
0
Bonsoir,
Oui il y a seulement ces 4 textes a renvoyer et c'est bien toujours les 2 dernières lettres qu'il faut transformer en texte.
Merci
0
PapyLuc51 Messages postés 3794 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 28 novembre 2022 1 195 > Nikiveve
20 avril 2021 à 03:01
OK j'avais quasiment la même réponse que via55 (salutations).

Cordialement
0
Merci beaucoup ça marche
0