Aide ppur formule

Signaler
-
 Nikiveve -
Bonjour,

Je ne m'en sors pas avec une formule ci dessous mon type de tableau:

A1 B1
IDF/AME/AQ/FO/078 Formulaire
IDF/IH/FI/096 Fiche
IDF/PO/PW/PR/043 Procedure
IDF/MI/MO/034 Mode operatoore

J'aimerais qu'excel trouve les 2 dernieres lettres de la cellule A1 soit "Fo" pour la 1ère ligner et que dans la cellule B1 il écrive "Formulaire"
Idem pour la 2ème ligne "FI" egal "fiche" dans B1 et ceci sur plus de 500 lignes.

Je suis perdue, je cherche depuis 2h avec la fonction SI ou Cheche voir les 2 mais je n'y arrive pas.

Pouvez-vous m'aider ?

Merci d'avance

Configuration: Android / Chrome 90.0.4430.66

4 réponses

Messages postés
2445
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
6 mai 2021
1 104
Bonsoir
A tester
=SI(ESTERREUR(TROUVE("FO";A1));"";"FO")&SI(ESTERREUR(TROUVE("FI";A1));"";"Fiche")&SI(ESTERREUR(TROUVE("PR";A1));"";"Procédure")&SI(ESTERREUR(TROUVE("MO";A1));"";"Mode opératoire")
Bonsoir,

Je vais tester demain. Je vous dirais si ça marche

Merci!!
Cdlt
Merci ça marche!!
Messages postés
13005
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
30 avril 2021
2 185
Bonjour

Un exemple à adapter
https://mon-partage.fr/f/eMX2azLI/

Cdlmnt
Via
Bonsoir,

Je vais voir si ça marche
Merci!!!
Cdlt
Messages postés
3245
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
5 mai 2021
905
Bonjour

Il n'y a que ces 4 textes à renvoyer (formulaire, Fiche, Procédure et Mode opératoire) ou il y en a plus ??
Les deux lettres à extraire sont-elles toujours en 5ème et 6ème position par rapport à la droite de la chaîne ??

Cordialement
Bonsoir,
Oui il y a seulement ces 4 textes a renvoyer et c'est bien toujours les 2 dernières lettres qu'il faut transformer en texte.
Merci
Messages postés
3245
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
5 mai 2021
905 > Nikiveve
OK j'avais quasiment la même réponse que via55 (salutations).

Cordialement
Merci beaucoup ça marche