Erreur formule Excel [Résolu]

Signaler
Messages postés
3
Date d'inscription
jeudi 25 mars 2021
Statut
Membre
Dernière intervention
25 mars 2021
-
Messages postés
3
Date d'inscription
jeudi 25 mars 2021
Statut
Membre
Dernière intervention
25 mars 2021
-
Bonjour,
Pourriez-vous me dire où est mon erreur dans cette formule :

=SI(ET(G4>=0; G4<= 20);5; SI(ET(G4>20; G4<=70);4; SI(ET(G4>70; G4<=200);3; SI(ET(G4>200; G4<=400);2; SI(ET(G4>400, G4<=10000);1; 0)))))

Excel ne me propose pas de solution et j'ai déjà essayé en remplaçant les ";" par des "," cela ne fonctionne toujours pas.

Merci de votre aide.



Configuration: Windows / Chrome 89.0.4389.90

2 réponses

Messages postés
770
Date d'inscription
dimanche 15 novembre 2015
Statut
Membre
Dernière intervention
5 avril 2021
131
Bonjour,

=SI(ET(G4>=0; G4<= 20);5; SI(ET(G4>20; G4<=70);4; SI(ET(G4>70; G4<=200);3; SI(ET(G4>200; G4<=400);2; SI(ET(G4>400, G4<=10000);1; 0)))))

G4>400, G4<=10000 tu as mis une virgule alors qu'il faut un ;

=SI(ET(G4>=0;G4<= 20);5;SI(ET(G4>20;G4<=70);4;SI(ET(G4>70;G4<=200);3;SI(ET(G4>200;G4<=400);2;SI(ET(G4>400;G4<=10000);1;0)))))


Slts
Messages postés
3
Date d'inscription
jeudi 25 mars 2021
Statut
Membre
Dernière intervention
25 mars 2021

Merci, j'avais le nez dessus !!!
Messages postés
53600
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
11 avril 2021
15 645
Salut.

D'autre part ta formule est inutilement compliquée, avec des tests en double ... Il suffit d'écrire :
=SI(G4>=0;SI(G4<=20;5;SI(G4<=70;4;SI(G4<=200;3;SI(G4<=400;2;SI(G4<=10000;1;0))))))
Messages postés
3
Date d'inscription
jeudi 25 mars 2021
Statut
Membre
Dernière intervention
25 mars 2021

Effectivement, plus simple
Merci