Transformer 03:30 en 3,50 (décimale)

Fermé
coucouexcel - Modifié le 24 févr. 2021 à 13:38
 coucouexcel - 26 févr. 2021 à 10:30
Bonjour,

J'ai un tableau où les salariés remplissent leurs heures. Cela m'a pris beaucoup de temps. Ils remplissent en entrant leurs horaires normalement, par exemple si ils ont travaillé de 15:00 à 17:30 mon excel indique le : 02:30
Ils ont aussi une balance, si ils n'ont pas fait toutes leurs heures il peut être indiqué : -03:30

Sauf que la comptabilité veut recevoir les heures en décimales. Il faut donc que je transforme ce -03:30 en -3,50.

Il y a t'il un calcul pour tout automatiser ?

Bonne journée,

11 réponses

JCB40
Messages postés
2625
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
17 août 2022
464
24 févr. 2021 à 13:46
Bonjour
Formule a mettre dans la cellule résultat attendu
=MOD(C5-B5;1)*24
Cordialement
0
Merci Beaucoup mais cela ne fonctionne pas avec des valeurs négatives...
0
PapyLuc51
Messages postés
3718
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
14 août 2022
1 144
Modifié le 24 févr. 2021 à 13:51
Bonjour

Pour transformer une heure en nombre avec décimales il faut la multiplier par 24

Soit en A1 15:00 et en B1 17:30

=B1*24-A1*24 
donne 2,50 dans une cellule mise au format nombre avec deux chiffres après la virgule

Cordialement
0
Merci Beaucoup mais cela ne fonctionne pas avec des valeurs négatives...
0
PapyLuc51
Messages postés
3718
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
14 août 2022
1 144
24 févr. 2021 à 14:35
Exact si ont fait la soustraction avant la mise en décimale - pour contourner les ##### est d'envelopper la soustraction par ABS() qui retire le signe mais l'inconvénient c'est que la transformation en décimale va faire un nombre positif que tu devras gérer ensuite.



Cordialement
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Merci, mais cela me rend davantage la tache compliquée... Mais merci
0
PapyLuc51
Messages postés
3718
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
14 août 2022
1 144
24 févr. 2021 à 14:56
Une formule qui ferait tout d'un seul coup sans passer par des calculs intermédiaires:

=SI(A1<B1;B1*24-A1*24;CNUM("-"&ABS(B1-A1)*24))


Si ça ne convient pas, envoie une copie du fichier sans les données confidentielles

Pour mettre un fichier en partage :
Aller dans https://www.cjoint.com/
Cliquer sur "PARCOURIR" pour sélectionner le classeur ou "FAIRE UN GLISSER DEPOSER" dans la fenêtre ;
Cliquer sur le bouton "CREER LE LIEN"
Faire un "CLIC DROIT" sur le lien créé "COPIER L'ADRESSE DU LIEN" ;
Sur le post Clic droit "COLLER".

ou dans https://mon-partage.fr/

Cordialement
0
Bonjour,

Mais je le fais pour une seule cellule, si je ne souhaite traduire que B1, le calcul : ne fonctionne pas...

Merci
0
eriiic
Messages postés
24431
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 août 2022
7 108
Modifié le 24 févr. 2021 à 23:00
Bonjour,

avec 19:00 en A2 et 17:00 en B2
=(B2-A2)*24
fonctionne très bien malgré un résultat négatif, les ### ne sont qu'un problème d'affichage et le résultat est correct.
Il faut juste remettre le format de cellule en Standard ou en format Nombre
eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
0
Bonjour,

Pour une valeur seule, par exemple B1 à -06:30 cela ne me met pas -06,50 mais Erreur. J'ai change le format de cellule et cela ne fonctionne pas...

Bonne journée,
0
PapyLuc51
Messages postés
3718
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
14 août 2022
1 144
25 févr. 2021 à 09:05
Bonjour

Pour être certain de répondre correctement à ton attente, il nous faudrait une copie de ton fichier sur lequel tu retires les données confidentielles et mentionnes quelques exemples.

Pour mettre un fichier en partage :
Aller dans https://www.cjoint.com/
Cliquer sur "PARCOURIR" pour sélectionner le classeur ou "FAIRE UN GLISSER DEPOSER" dans la fenêtre ;
Cliquer sur le bouton "CREER LE LIEN"
Faire un "CLIC DROIT" sur le lien créé "COPIER L'ADRESSE DU LIEN" ;
Sur le post Clic droit "COLLER".

ou dans https://mon-partage.fr/

Cordialement
0
https://www.cjoint.com/c/KBzimukWBHX

Le voici, il faut que je retranscrive ces valeurs en décimales pour la compta
0
PapyLuc51
Messages postés
3718
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
14 août 2022
1 144
Modifié le 25 févr. 2021 à 09:46
Tu n'indiques pas les cellules à transformer ??? R2 à Z2 ??? Ou mettre le résultat ailleurs ??? En faisant comme l'a indiqué eric que je salue ça devrait le faire.

En plus il y a des liaisons qu'elles sont les heures ; B2 et C2 indiquent 0:00

Cordialement
0
eriiic
Messages postés
24431
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 août 2022
7 108
25 févr. 2021 à 10:53
Bonjour,

"-120:06" n'est pas une valeur numérique résultant d'un calcul mais du texte.
Il faut donc travailler sur la chaine :
=SUBSTITUE(F4;"-";"")*24*-(GAUCHE(F4;1)="-") 


On bien récupérer la vraie valeur numérique (même s'il y a des ###) dans BARKET Akila - Horaires 2021.xlsx et non la chaine fabriquée pour afficher un temps négatif.
C'est ce qu'il y aurait de mieux.
eric
0
Je ne comprends pas.

Votre calcul fonctionne mais pas pour les valeurs positives...
0
eriiic
Messages postés
24431
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 août 2022
7 108 > coucouexcel
25 févr. 2021 à 20:30
Normal. Fait à l'arrache avant de partir je n'ai pas testé l'autre cas...
Utilise plutôt :
=SI(GAUCHE(F4;1)="-";STXT(F4;2;10)*-24;F4*24)  

eric
0
coucouexcel > eriiic
Messages postés
24431
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 août 2022

26 févr. 2021 à 10:30
Cela fonctionne... Merci beaucoup, vous me sauvez.
Bonne journée.
0