Formule exel

Signaler
-
 xavier -
Bonjour, je suis novice mais courageux...
Alors j'ai un tableau avec 10 colonnes et 30 lignes. Chaque cellules a un menu deroulant avec prénoms (validation des donnees).la 10e colone formule nb.si.
Question ❓.comment créer une alerte lorsque l'on met 3 ou 4 fois le même prénom sur une même ligne...sans perdre mes menus deroulant...
Question ❓ oubien limiter a 3 ou 4 fois le même prénom sur la ligne...
Merci infiniment



Configuration: Android / Chrome 88.0.4324.181

5 réponses

Messages postés
1031
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
25 février 2021
214
Re,
Ok , j'ai mieux compris la demande, je vais voir pour élaborer une petite macro pour gérer cela
(Fin d'AM ou demain matin)
RdV cette AM
> xavier
Ouiiiiiiii....nickel pour le fait que l'on ne puisse mettre un nom x fois sur la même ligne...
Vraiment merci
Et pour ma cellule J1 qui n'est que la sommes NB.SI de certains prénoms.. comment créer lun message d''alerte lorsque cette cellule a atteint le chiffres 3 par exemple...
Merci M12
> xavier
OUPSS J'ai bugger .... J'ai ouvert avec mon tel télécharger ton fichier sans voir que c'était celui du matin enfin... plus les pub a tout va. bon je restes présent pour ta solution a mon problème...
merci a vous.
Messages postés
1031
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
25 février 2021
214
Bonjour,
Un test avec MFC
https://mon-partage.fr/f/oGKZqcHB/
Bonjour M-12 et merci déjà pour ta réponse;
Ca ressemble bien ton tableau, mais ce que je cherche a faire c'est lorsque tu mets 3 fois PAUL..qu' Excel t'empêche ..de le mettre une 4 fois...et de plus lorsque tu arrive a 3 dans la denier colonne nb.si un message d'erreurs s'affiche.
exemple; ligne 1 je mets trois fois paul....a la 4 cela doit être impossible de l'afficher.et dans ma colonne J1 ou se trouve ma formule =NB.SI(A1:I1;"PAUL") donc total des PAUL lorsque ma cellule J1 arrive a 3 un message d'alerte s'affiche. voila....
déjà un grand merci pour ton temps
Messages postés
1031
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
25 février 2021
214
Bonsoir,
Teste ceci. Les colonnes P aS peuvent être masquées
https://mon-partage.fr/f/ByWYtn7f/
bonjour,M12
super le boulot!!!
mais il y a un ptit souci...
Exemple: lorsque je mets Léon 3fois sur la même ligne, il y a bien un ptit message de rappel super "3 fois Léon". Mais du coup si j'en supprime un pour le mettre dans une autres cellules de la même ligne, je ne peux plus car il a disparu de la liste déroulante.je parle de lignes car la formule doit être pour chaque lignes et non pour l'ensemble du tableau. En plus simple "3 Léon ligne 1... A1 C1 E1 si j'efface E1 pour le mettre en H1 cela n'est plus possible car Léon a disparu du menu déroulant.ET si je décents ligne A3 ou A'4.....A5 plus de Léon dans le menu déroulant;
je ne veux également pas, abuser de votre gentillesse et de votre temps.
et teins a vous remercier d'avance M12