Aide sur une formule conditionnelle

Signaler
-
 olilouo -
Bonjour,

Me revoilà avec mon planning de charge pour lequel j'avais été bien aidée par Michel.
j'ai rajouté la colonne F : https://mon-partage.fr/f/NAHuRVL8/
de G146 à G178 j'ai la somme en heures en fonction des personnes.
j'aimerais rajouter l'option qui est dans la colonne F c'est à dire obligatoire ou non
en résumé : j'aimerais que dans la cellule G180 avoir la somme en heures (qui est dans la colonne E) à condition à chaque ligne que pour la semaine 1 j'ai qq un d'écrit dans la colonne G et que dans la colonne F il soit écrit "obligatoire"
si je prends l'exemple des lignes 1 à 10 : ca devrait me faire la somme de (15,4+3+0,8) pour la semaine 1
et si je prends la ligne 21 par exemple ca ne devrait pas me le compter dans la somme car même si obligatoire en F, pas de nom en G.
j'ai essayé de rajouter une condition ET... mais je n'y arrive pas, je pense ne pas la mettre au bon endroit.

Merci d'avance de votre aide!
ML



Configuration: Windows / Edge 88.0.705.74

2 réponses

Messages postés
1038
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
7 mars 2021
216
Bonjour,
Teste avec cette formule en G180
=SOMME.SI.ENS(E2:E143;C2:C143;1;G2:G143;"<>""";F2:F143;"obligatoire")
Bonsoir,
effectivement ca marche en G180
par contre si je suis la formule et que je souhaite que ca marche en H180 :
=SOMME.SI.ENS(E2:E143;C2:C143;2;H2:H143;"<>""";F2:F143;"obligatoire")

sauf que la formule va aller me chercher le nombre 2 dans la colonne C
c'est cela?
du coup ca ne prendra pas si c'est écrit 1 dans C et 7 dans D ( ce qui veut dire que ca se fait de semaine 1 à 7) donc en semaine 2 aussi
c'est pour ca que j'avais fait une formule SI compris entre X et X