Si et serie.jour.ouvre.intl [Résolu]

Signaler
-
Messages postés
25816
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 février 2021
-
Bonjour,

Malgré de nombreuses recherches, je n'arrive pas à computer les formules si et serie.jour.ouvre.intl

si(b4="pref";"";serie.jour.ouvre.intl(B24;-1;1;liste!$f$2:$f$16))

Je souhaite obtenir :
Si cellule b24 contient "pref" ne rien faire ;
Dans le cas contraire, si cellule b24 ne contient pas "pref" soustraire 1 jour ouvré à la cellule b24 (en fonctions des jours ouvrés et de ma liste de jours fériés).

Ma formule serie.jour.ouvre.intl fonctionne très bien lorsqu'elle est toute seul, c'est juste que j'arrive pas à la cumuler avec la formule SI.

J'obtiens le message "valeur"

Merci de votre aide

Isabelle


Configuration: Windows / Chrome 88.0.4324.182

3 réponses

Messages postés
25816
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 février 2021
5 784
Alors je viens de tester et la formule fonctionne bien dans tous les cas saufs:
  • si B24 est vide, la cellule renvoi #NOMBRE
  • si B24 contient autre chose qu'une date ou que le texte "pref", elle renvoie #VALEUR

êtes vous sur que le texte qui s'affiche en B24 est bien identique à celui de la formule (blancs éventuels, accents, etc..? et si oui, déposez votre modèle par exemple ici et revenez coller le lien créé sur le site
https://mon-partage.fr
D'autre part, si vous avez aussi d'autres choses ou rien en B24, et que vous voulez éliminer l'avertissement en conséquence, vous pouvez simplement écrire:
=SIERREUR(SERIE.JOUR.OUVRE.INTL(B24;-1;1;liste!$F$2:$F$16);"")
à vous lire
crdlmnt
Vaucluse

Je vous remercie, vous venez de trouver la solution à mon problème. Je ne connaissais pas la formule SIERREUR je suis pas très calée en formule. Ca fonctionne trop bien vous me sauvez d'une énorme migraine !!! Merci beaucoup..
Messages postés
25816
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 février 2021
5 784
Pas de quoi
je passe en résolu
Bonne route
crdlmnt
Messages postés
25816
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 février 2021
5 784
bonjour
votre formule fait référence à B4 au début etB24 ensuite?
Oui c'est une erreur en recopiant c'est B24