Calcul d'une serie a l'aide d'une equation

Signaler
-
Messages postés
1
Date d'inscription
vendredi 19 février 2021
Statut
Membre
Dernière intervention
19 février 2021
-
Bonjour,

je debute avec Excel mais je n'ai pas le choix de l'utiliser pour un projet d'etude.

Je ne suis pas sur de pouvoir faire ce dont j'ai besoin avec excel c'est pourquoi je me permets de poser la question ici , est il possible de realiser ceci sur excel :

- attribuer a x des valeurs de 0 a L avec un pas de 0,1 ou 0,01.

- realiser une equation pour tout les x qui seront entre 0 et L ( M(x) = "equation" + A(x)) sachant que A(x) changera si x depasse une certaine valeur ( ex : si x ≤ xi faire "equation" si x > xi faire "equation" )

- Le resultat sous forme de colonne avec la valeur attribuée pour chaque x

(les valeurs telles que L ou xi seront determinées avant)

Merci d'avance ;)

2 réponses

Messages postés
23911
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
6 mars 2021
6 672
Bonjour,

mettre 0 en A2, et
=A2+0.1
en A3 que tu tires vers le bas.

En B2 :
=SI(A2<=1;formule1;SI(A2<=2;formule2;SI(A2<=3;formule3)))

tu peux ajouter d'autres Si() de la même façon
eric
Messages postés
1
Date d'inscription
vendredi 19 février 2021
Statut
Membre
Dernière intervention
19 février 2021

Super, merci beaucoup,
mais y a t il un moyen que la serie de nombre s'afiche automatiquement ?
Pour que lorsque je marque mon max dans une case ( qui changera a chaque utilisation ) il y ait directement la liste avec tous les nombres entre 0 et mon max avec un interval de 0,1 entre chaque ?
Merci encore
Messages postés
9680
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
3 mars 2021
2 048
Bonjour à tous les deux

Un petit exemple
https://www.cjoint.com/c/KBtmS2QCcSB

Cdlmnt