Compter les weekends calendrier

Signaler
-
 Amnexia -
Bonjour j'aimerai calculer les jours de repos restant et sachant que les weekend ne sont pas compter même si le jour est posé durant le weekend, quel calcule me conseillerai vous

calcule de base pour vous le nombre de jour posé.
=NB.SI(Janvier!$F17:$AJ17; "w") + NB.SI('Février'!$G17:$AK17; "w") + NB.SI(Mars!$G17:$AK17; "w") + NB.SI(Avril!$F17:$AJ17; "w") + NB.SI(Mai!$F17:$AJ17; "w") + NB.SI(Juin!$F17:$AJ17; "w") + NB.SI(Juillet!$F17:$AJ17; "w") + NB.SI('Août'!$F17:$AJ17; "w") + NB.SI(Septembre!$F17:$AJ17; "w") + NB.SI(Octobre!$F17:$AJ17; "w") + NB.SI(Novembre!$F17:$AJ17; "w") + NB.SI('Décembre'!$F17:$AJ17; "w")

F17 -> AJ17 = du 1er janvier au 31 janvier etc etc

calcule qui permet d'afficher les jours restants mais le problème c'est que les weekend sont compris dedans et j'aimerai ne pas les compter justement.
=SI(A17="";; 45-BDD!$E2)
A17 = E2 sur la bdd = même user

Merci

2 réponses

En gros en expliquant ce que je cherche mais fonctionnel
je veux que sur la line 28 entre F28 et AJ28 avec le contenu de la cellule = "w" que ça récupère le samedi et le dimanche ( seulement si y'a le "w" dans la cellule ) et que ça compte le nombre de "w" dans les weekend de la ligne horizontal choisit

=NB.SI(F28:AJ28="w"; JOURSEM(F10:AJ10;2)>5)
SOMMEPROD(Janvier!$F17:$AJ17="w"; JOURSEM(Janvier!$F$10:$AJ$10;2)>5)

Voila la solution trouvé pour ce problème, souvent je dois d'abord demander de l'aide et je finit par trouver plus tard
En gros cette formule dit :

Partit plage :
Je compte tout avec le critère de texte "w" sur la plage F17 a AJ17
Partit critère :
Je cherche à récupérer que les weekend
F10 a AJ10 ce sont mes dates donc du 1er janvier au 31 janvier, le 2 c'est pour commencer la semaine le lundi, et le >5 je suppose que c'est pour dire que je veux les samedi et dimanche seulement. ( même code que pour grisé les weekend en mise en forme conditionnelle ).