Formule nombre de jours dans groupes de jours

Signaler
Messages postés
5
Date d'inscription
mercredi 29 juillet 2020
Statut
Membre
Dernière intervention
7 janvier 2021
-
Messages postés
2421
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
7 janvier 2021
-
Bonjour, le titre n'est pas du tout compréhensible je m'en doute donc je vais essayer de vous expliquer au mieux mon problème.

CONTEXTE :
Je dois créer un document Excel pour répertorier les accidents de travail ayant lieu dans mon entreprise. J'ai donc fais ceci et en plus j'ai créé une feuille avec des beaux graphiques et belles formules que j'utiliserai durant le CSSCT.

Un des service de mon entreprise travail en 5*8 (nous appellerons ce service "X"). Tous les autres services travaillons du lundi au vendredi.
J'ai besoin de connaître les jours de travail manqués si un salarié de l'entreprise est en arrêt de travail (Pour tous les services qui sont en repos les samedis et dimanches, c'est facile de calculer avec la formule NB.JOURS.OUVRES.INTL).
Les jours de repos du service "X" ne sont pas fixes et varient tout le temps (Ils travaillent 6 jours d'affilés et sont 4 jours de repos, puis retravaillent 6 jours d'affilés et sont de nouveaux en repos 4 jours, etc.etc.). Vous voyez certainement où je veux en venir...

PROBLEME :
Quelle(s) formule(s) (imbriquée(s) ou non) dois-je utiliser pour calculer le nombre de jours de travail manqués pour le service "X" en sachant que leurs "week-ends" durent 4 jours et peuvent être n'importe quels jours de la semaine ?
J'espère avoir été assez clair et précis dans mes explications...

EXPLICATIONS BONUS : la formule (en langage humain) que j'aimerai faire comprendre à Excel serait :
Soustrais la date de fin d'arrêt de travail avec la date de début d'arrêt de travail en ignorant les week-end et jours fériés. Si le service concerné est le service "X", alors soustrais la date de fin d'arrêt de travail avec la date de début d'arrêt de travail en ignorant leurs week-ends qui sont 4 jours sur une période de 10 jours (6 jours de travail et 4 jours de repos).

Merci d'avance et bonne chance camarades informaticiens !

2 réponses

Messages postés
2421
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
7 janvier 2021
919
Bonjour,
Faire une liste des jours de repos pour les X.
Premier jour en A2. F2=$A$2+MOD(LIGNES($1:1)-1;4)+ENT((LIGNES($1:1)-1)/4)*10 à recopier vers le bas.
Période entre B1 et B2, le nombre de jours de repos est (selon J.Boisgontier)
=SOMMEPROD(NB.SI($F$2:$F$150;LIGNE(INDIRECT(B1&":"&B2))))

Je vous laisse calculer le nombre de jours de travail.
Messages postés
5
Date d'inscription
mercredi 29 juillet 2020
Statut
Membre
Dernière intervention
7 janvier 2021

Bonjour, tout d'abord merci de votre aide.

Ensuite, je n'ai vraiment pas compris. Pouvez-vous m'expliquer votre réponse SVP ?

Cordialement
Messages postés
2421
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
7 janvier 2021
919
Que n'avez -vous pas compris?
Le procédé global? Une fonction en particulier? un assemblage de fonctions?