Formule de calcul statistique

Résolu/Fermé
jedilu4269 Messages postés 4 Date d'inscription jeudi 7 janvier 2021 Statut Membre Dernière intervention 8 janvier 2021 - 7 janv. 2021 à 01:22
jedilu4269 Messages postés 4 Date d'inscription jeudi 7 janvier 2021 Statut Membre Dernière intervention 8 janvier 2021 - 8 janv. 2021 à 10:00
Bonjour,
j'utilise OpenOffice calc (Version 8.4.1) sous windows 10 home 64 bits et j'ai besoin d'aide pour calculer la "statistique de numéros sortie ensemble" situé dans une meme colonne mais dans plusieurs lignes et ordres différents.
L'exemple du tableau montre que mes cellules se trouvent en Colonne C "arrivée"
je voudrais a partir de cette colonne que mon calcul m'indique combien de fois sont sortie le nombre 11 et 2 ensemble.
Dans mon tableau on voit qu'ils sont sortie ensemble 2 fois le 27/12/2020 et le 31/12/2020,
idem pour le 1 et 2 sortie2 fois ensemble le 29/12/2020 et le 30/12/2020

Ma question est quel formule de calcul utilisée pour trouver ce résultat soit dans un cellule ou sous forme de tableau prenant en compte plusieurs numéros à comparer (numéros entre 1 et 16) ou alors y a t'il déjà dans OpenOffice calc cette fonction que je ne connais pas encore.
Merci d'avance





Configuration: Windows / Edge 87.0.664.66

2 réponses

Raymond PENTIER Messages postés 56979 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 26 janvier 2023 17 174
7 janv. 2021 à 01:36
Bonjour.

Tous les tableurs (Calc, Excel, Numbers, Gnuméric, Google Sheets, etc) fonctionnent suivant le même principe pour les calculs : UNE DONNÉE PAR CELLULE !
Tes cellules qui contiennent des chiffres et des tirets ne sont pas utilisables, car leurs contenus sont des textes ...
Tu dois reprendre entièrement ton tableau, et remplacer ta cellule C3 par 5 cellules contenant chacune un seul nombre. Pareil pour toutes les autres des colonnes B et C.
0
jedilu4269 Messages postés 4 Date d'inscription jeudi 7 janvier 2021 Statut Membre Dernière intervention 8 janvier 2021
7 janv. 2021 à 02:10
Merci Raymond pour votre réponse mais seule la colonne C m'intéresse pour effectuer ma statistique car je veux comparer que les nombres de ce champ, la colonne A et B je n'en tiens pas compte. Sinon quel est la formule de calcul a utilisé pour cela afin d'adapter et modifié mon tableau en colonne C suivant la méthode.
0
yclik Messages postés 3100 Date d'inscription vendredi 25 juillet 2014 Statut Membre Dernière intervention 26 janvier 2023 1 390 > jedilu4269 Messages postés 4 Date d'inscription jeudi 7 janvier 2021 Statut Membre Dernière intervention 8 janvier 2021
Modifié le 7 janv. 2021 à 17:21
0
jedilu4269 Messages postés 4 Date d'inscription jeudi 7 janvier 2021 Statut Membre Dernière intervention 8 janvier 2021 > yclik Messages postés 3100 Date d'inscription vendredi 25 juillet 2014 Statut Membre Dernière intervention 26 janvier 2023
8 janv. 2021 à 10:00
Merci Yclik pour votre réponse mais on ma donner la solution du problème:

=SI(ET(NB.SI(C14:G14;C14);NB.SI(C14:G14;F14));"oui";"non")
0
Raymond PENTIER Messages postés 56979 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 26 janvier 2023 17 174
7 janv. 2021 à 18:04

Tu insistes beaucoup ! J'ai bien trouvé une procédure sur Excel, qu'il faudrait transposer dans Calc.
Cette procédure nécessite de :
- créer en colonne D une fonction définie nommée "tirets", qui ajoute un tiret au début et à la fin de tes données en colonne C
- créer un mini-tableau en E2:F3 pour saisir les données à tester et leur affecter les noms définis "Nb_1" et "Nb_2"
- appliquer aussi la fonction définie "tirets" en G2 et G3
- saisir en H2 la fonction finale qui utilise ces résultats intermédiaires :
=NB.SI.ENS(D:D;"*"&G2&"*";D:D;"*"&G3&"*").
https://www.cjoint.com/c/KAhradMuPab
Tu vois que ce n'est pas simple ; et ce sera délicat à "adapter et modifier", comme tu ambitionnes de le faire !
0