Formule de calcul statistique [Résolu]

Signaler
Messages postés
4
Date d'inscription
jeudi 7 janvier 2021
Statut
Membre
Dernière intervention
8 janvier 2021
-
Messages postés
4
Date d'inscription
jeudi 7 janvier 2021
Statut
Membre
Dernière intervention
8 janvier 2021
-
Bonjour,
j'utilise OpenOffice calc (Version 8.4.1) sous windows 10 home 64 bits et j'ai besoin d'aide pour calculer la "statistique de numéros sortie ensemble" situé dans une meme colonne mais dans plusieurs lignes et ordres différents.
L'exemple du tableau montre que mes cellules se trouvent en Colonne C "arrivée"
je voudrais a partir de cette colonne que mon calcul m'indique combien de fois sont sortie le nombre 11 et 2 ensemble.
Dans mon tableau on voit qu'ils sont sortie ensemble 2 fois le 27/12/2020 et le 31/12/2020,
idem pour le 1 et 2 sortie2 fois ensemble le 29/12/2020 et le 30/12/2020

Ma question est quel formule de calcul utilisée pour trouver ce résultat soit dans un cellule ou sous forme de tableau prenant en compte plusieurs numéros à comparer (numéros entre 1 et 16) ou alors y a t'il déjà dans OpenOffice calc cette fonction que je ne connais pas encore.
Merci d'avance





Configuration: Windows / Edge 87.0.664.66

2 réponses

Messages postés
53095
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
16 janvier 2021
15 069
Bonjour.

Tous les tableurs (Calc, Excel, Numbers, Gnuméric, Google Sheets, etc) fonctionnent suivant le même principe pour les calculs : UNE DONNÉE PAR CELLULE !
Tes cellules qui contiennent des chiffres et des tirets ne sont pas utilisables, car leurs contenus sont des textes ...
Tu dois reprendre entièrement ton tableau, et remplacer ta cellule C3 par 5 cellules contenant chacune un seul nombre. Pareil pour toutes les autres des colonnes B et C.
Messages postés
4
Date d'inscription
jeudi 7 janvier 2021
Statut
Membre
Dernière intervention
8 janvier 2021

Merci Raymond pour votre réponse mais seule la colonne C m'intéresse pour effectuer ma statistique car je veux comparer que les nombres de ce champ, la colonne A et B je n'en tiens pas compte. Sinon quel est la formule de calcul a utilisé pour cela afin d'adapter et modifié mon tableau en colonne C suivant la méthode.
Messages postés
2260
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
14 janvier 2021
963 >
Messages postés
4
Date d'inscription
jeudi 7 janvier 2021
Statut
Membre
Dernière intervention
8 janvier 2021

Messages postés
4
Date d'inscription
jeudi 7 janvier 2021
Statut
Membre
Dernière intervention
8 janvier 2021
>
Messages postés
2260
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
14 janvier 2021

Merci Yclik pour votre réponse mais on ma donner la solution du problème:

=SI(ET(NB.SI(C14:G14;C14);NB.SI(C14:G14;F14));"oui";"non")
Messages postés
53095
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
16 janvier 2021
15 069

Tu insistes beaucoup ! J'ai bien trouvé une procédure sur Excel, qu'il faudrait transposer dans Calc.
Cette procédure nécessite de :
- créer en colonne D une fonction définie nommée "tirets", qui ajoute un tiret au début et à la fin de tes données en colonne C
- créer un mini-tableau en E2:F3 pour saisir les données à tester et leur affecter les noms définis "Nb_1" et "Nb_2"
- appliquer aussi la fonction définie "tirets" en G2 et G3
- saisir en H2 la fonction finale qui utilise ces résultats intermédiaires :
=NB.SI.ENS(D:D;"*"&G2&"*";D:D;"*"&G3&"*").
https://www.cjoint.com/c/KAhradMuPab
Tu vois que ce n'est pas simple ; et ce sera délicat à "adapter et modifier", comme tu ambitionnes de le faire !