Pb liaison entre deux classeurs excel

Signaler
-
 Sebioux -
Bonjour,

J'ai un souci de liaison entre deux classeurs EXCEL.
Depuis ce matin, le sigle "#REF" apparaît dans toutes les lignes en complément des formules existantes.
J'ai rompu la liaison existante, même en créant une nouvelle liaison, les valeurs ne se mettent pas à jour (pas de message d'erreur).
Merci pour votre aide.

3 réponses

Messages postés
23801
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
14 janvier 2021
6 568
Bonjour,

excel est incapable de deviner les références ayant disparu et les note "#REF".
C'est à toi de corriger toutes les formules en mettant la bonne référence de cellule ou plage.
eric
Bonjour Eric,

Jusqu'à alors, l'actualisation se faisait sans problème.
Tous les liens (environ une centaine). Ci-dessous un exemple ;
=SIERREUR(RECHERCHEV($K296;#REF!;8;FAUX);0)
Messages postés
23801
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
14 janvier 2021
6 568
Oui.
Et bien #REF! indique une plage qui a disparue, et excel est incapable de l'inventer.
Toi seul sais où ce trouve ce tableau et tu dois lui indiquer en mettant sa référence dans la formule.
eric
>
Messages postés
23801
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
14 janvier 2021

Je vais donc investiguer afin de comprendre ce qui a bien pu se passer.
Merci pour ton retour.
Messages postés
23801
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
14 janvier 2021
6 568 > Sebioux
Le plus souvent c'est quand on supprime une plage au lieu de l'effacer, ou bien une feuille.
Toujours se faire des backups réguliers des fichiers importants pour pouvoir revenir en arrière en cas de cagade.
eric
Bonjour,

Après recherches, il s'avère que mon problème de liaison provenait du serveur.
En effet, mon accès au réseau se faisait par Y/Public/... alors que le fichier que j'utilisais en VPN était sur Z/Public/....
Je pouvais accéder au fichier mais lorsque j’enregistrais mes données, EXCEL buguait.
Voilà, si ça peut aider...
Sebioux