Comment Afficher cellule si texte sinon rien [Résolu]

Signaler
-
 MiX -
Bonjour,

J'ai un colonne source qui contient du texte et des nombres et je cherche à afficher le contenu d'une cellule si celle-ci contient du texte, sinon je ne veux rien afficher.

Voici ma feuille Excel:
En colonne A j'ai :
A1= 10.00
A2= 1.00
A3=Full Authority

En colonne B, je veux afficher du texte lorsque A en contient, sinon rien:
B1=
B2=
B3=Full Authority

Pourriez-vous m'aider à trouver la bonne formule Excel svp?

Ensuite, je voudrais faire le même exercice en colonne C mais en n'affichant que les montants.
Merci!

Configuration: Windows / Edge 87.0.664.55

2 réponses

Messages postés
12235
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
6 janvier 2021
2 555
Bonjour,

Attention, les nombres doivent être de "vrais nombres" au sens ou Excel l'entends. Gare aux séparateurs.

En colonne B :
=SI(ESTTEXTE(A1);A1;"")

En colonne C :
=SI(ESTNONTEXTE(A1);A1;"")

Merci Pijaku pour la précision. C'est bien la formule que j'avais utilisé et je comprends pourquoi elle ne marche par pour mon cas qui contient des points "." qu'Excel considère comme du texte j'imagine....!

Est-ce que tu aurais une formule pour n'afficher que les chaines de caractères du coup?
(et pas les montants qui contiennent des points)

Merci.
Messages postés
12235
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
6 janvier 2021
2 555 > MiX
Un exemple :
Pour la colonne B :
=SI(ESTERREUR(SUBSTITUE(A1;".";",")/1);A1;"")

Pour la colonne C (l'inverse) :
=SI(ESTERREUR(SUBSTITUE(A1;".";",")/1);"";A1)
Ca fonctionne bien cette fois, Merci bcp !