Recherche de 2 valeurs spécifiques dans 2 colonnes différentes et afficher un X [Résolu]

Signaler
Messages postés
29
Date d'inscription
mercredi 22 mai 2019
Statut
Membre
Dernière intervention
1 décembre 2020
-
Messages postés
29
Date d'inscription
mercredi 22 mai 2019
Statut
Membre
Dernière intervention
1 décembre 2020
-
Bonjour,

Je tente de rechercher 2 valeurs spécifiques dans 2 colonnes différentes.

L'index-Equiv fonctionne bien pour une colonne et une ligne, mais là je dois trouver les éléments dans 2 colonnes.

Pouvez-vous m'aider svp!!!

Merci!!

Voici le fichier : https://mon-partage.fr/f/wuEku6sr/

2 réponses

Messages postés
25751
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 janvier 2021
5 715
Bonjour
pas sur d'avoir compris, mais je propose avant d'en savoir plus en C9 cette formule qui, si les sont bien placés devrait pouvoir se coller sur tout le tableau
=SIERREUR(SI(INDEX(Feuil3!$I:$I;EQUIV(C$2;Feuil3!$A:$A;0))=$B9;"X";"");"")
et si ça ne convient pas, revenez en complétant les explications
crdlmnt

Messages postés
29
Date d'inscription
mercredi 22 mai 2019
Statut
Membre
Dernière intervention
1 décembre 2020

Merci beaucoup Vaucluse,
Ça fait exactement ce que j'ai besoin.
Messages postés
25751
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 janvier 2021
5 715
à suivre quand même, car ça ne fonctionne que si vous n'avez qu'une seule ligne du même code en A de feuil3
si vous l'avez plusieurs fois pour des valeurs différentes en I, il faudra voir le problème autrement, par exemple avec, en C9 à coller sur le tableau

=SI(SOMMEPROD((Feuil3!$A$1:$A$1000=C$2)*(Feuil3!$I$1:$I$1000=$B9))>0;"X";"")

avec cette formule, mieux vaut limiter les champs en nombre de lignes

si tout cela vous convient, merci de passer le sujet en résolu en cliquant sur le bouton vert en dessous de votre premier post
bonne route

crdlmnt
Messages postés
29
Date d'inscription
mercredi 22 mai 2019
Statut
Membre
Dernière intervention
1 décembre 2020

En effet, c'est bien la 2e formule qu'il me fallait.

Merci énormément pour vôtre aide!!