Formule NBRE.SI.ENS avec nombres pair/impair [Résolu]

Signaler
Messages postés
3
Date d'inscription
mardi 1 décembre 2020
Statut
Membre
Dernière intervention
1 décembre 2020
-
Messages postés
2956
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
15 janvier 2021
-
Bonjour,
je cherche désespérément sans trouver comment faire la somme des chiffres pair et impairs dans une fonction NBRE.SI.ENS
je m'explique :
J'ai
- dans la colonne D des noms de rues
- dans la colonne E les numéros des maisons

certaines rues se trouvent sur deux secteurs différents = coté pair le secteur A, coté impair le secteur B.
Je cherche donc à déterminer ceci : combien d'occurrence présentent à la fois les caractéristiques : dans la colonne D "Boulevard machin", dans la colonne E "nombre pair" pour savoir combien d'adresses se trouvent dans le secteur A et combien dans le secteur B.

J'ai réussi à trouver la formule si le numéro est supérieur ou inférieur à un certain nombre :
=NB.SI.ENS('janvier 2021'!D2:D10000;J25;'janvier 2021'!E2:E10000;"<=513") (J25 étant le nom de la rue).
Je voudrais donc que la dernière partie de la formule détermine non pas si le numéro est supérieur à 513, mais s'il est pair.

merci beaucoup!

3 réponses

Messages postés
23802
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
16 janvier 2021
6 568
Bonjour à tous,

ou bien en validation normale :
=SOMMEPROD((MOD(E2:E14;2)=0)*(E2:E14<=513)*(D2:D14="Boulevard machin")) 

nb pairs <=513 du Boulevard machin
eric
Messages postés
2956
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
15 janvier 2021
411
Bonjour à tous,

Tu ne peux pas utiliser NB.SI.ENS(), car les arguments sont du texte, et on ne peut pas faire d'opérations sur du texte.
Tu dois passer par une colonne intermédiaire qui va te dire si ton adresse est paire ou impaire ==>
=si(mod(e2;2)=0;"pair";"") et apres nb.si.ens()

ou par une formule matricielle qui peut l'intégrer directement.

=nb(si((mod('janvier 2021'!E2:E10000;2)=0)*('janvier 2021'!D2:D10000=J25);'janvier 2021'!E2:E10000))

C'est une formule matricielle, donc à valider par
Maj+Ctrl+Entrée (les 3 doigts en même temps) pour faire apparaître les accolades.
Elle doit s'afficher automatiquement entre accolades dans la barre de formule, et être re-validée de la même façon à chaque fois qu'on y touche.
Messages postés
3
Date d'inscription
mardi 1 décembre 2020
Statut
Membre
Dernière intervention
1 décembre 2020

Super, la formule matricielle fonctionne! Merci!
Quelle est la modification à y apporter pour ne compter que les nombres impairs?
Messages postés
2956
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
15 janvier 2021
411
mod('janvier 2021'!E2:E10000;2)=1
Messages postés
3
Date d'inscription
mardi 1 décembre 2020
Statut
Membre
Dernière intervention
1 décembre 2020
>
Messages postés
2956
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
15 janvier 2021

Youpi! merci! :-)
Messages postés
2956
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
15 janvier 2021
411 >
Messages postés
3
Date d'inscription
mardi 1 décembre 2020
Statut
Membre
Dernière intervention
1 décembre 2020

Si tu as terminé, mets en résolu
Merci