Formule

Signaler
-
Messages postés
25660
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
3 décembre 2020
-
Bonjour,

je voudrais faire un tableau avec dans la colonne A2 un prénom et dans la colonne B2 un nombre exemple marine code 756 et en saisissant le nom que le nombre s 'affiche dans la case directement en fonction de chaque prénom. Avez vous une idée svp? Merci

2 réponses

Messages postés
25660
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
3 décembre 2020
5 646
Bonjour
il faut d'abord construire une base de données
par exemple,
  • en feuille 1 colonne A le prénom et en colonne B le code associé
  • en feuil2, en A à partir de A2 un menu déroulant pour choisir le prénom et en B la formule ci dessous si on commence en ligne 2:

=SIERREUR(RECHERCHEV(A2;feuil1!A:B;2;0);"")
crdlmnt
Comment créer une liste derourante ? Cordialement
Messages postés
25660
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
3 décembre 2020
5 646
Pour le plus pratique, selon l'exemple précédent
  • allez en feuil1 (base de données)
  • sélectionnez la ,liste de noms de la colonne A
  • Onglet FORMULES > Zone "noms définis" > "définir un nom"
  • dans la case nom, inscrivez le nom souhaité (exemple: noms)
  • et OK

venez dans la feuille d'édition
  • sélectionnez le champ à équiper
  • onglet DONNEES > Zone "Outils de données" > "validation des données"
  • dans la fenêtre cadre du haut(autoriser) sélectionnez "liste"
  • dans le cadre du bas entrez

=noms (où le nom que vous avez donné à la base)
  • et Ok

crdlmnt