Convertir des codes barres

Signaler
Messages postés
6
Date d'inscription
vendredi 16 octobre 2020
Statut
Membre
Dernière intervention
17 novembre 2020
-
Messages postés
6
Date d'inscription
vendredi 16 octobre 2020
Statut
Membre
Dernière intervention
17 novembre 2020
-
Bonjour,
Etant une association montagne, nous avons des livres et cartes qui sont empruntés. J'ai proposé de réaliser un fichier Excel avec lecture des codes barres ISBN13 des livres.
Mais sur Excel j'obtiens dans la cellule des chiffres et non le titre du bouquin.
Comment faire ?
Merci


Configuration: Windows / Chrome 86.0.4240.198

3 réponses

Messages postés
2552
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
2 décembre 2020
431
Bonjour,

C'est normal, les codes ISBN sont des chiffres, il faut ensuite chercher dans les bases de donnée pour trouver quel livre correspond à cette "référence".
https://www.afnil.org/isbn/

Par exemple si je cherche l'ISBN13 "978-2800157108" sur https://isbndb.com/ je trouve bien le livre correspondant. Il y'a des outils pour venir lire ces bases directement depuis Excel, un exemple pour ce site: https://stackoverflow.com/questions/2454348/isbn-bookdata-lookup-to-fill-in-a-database

Cordialement.
Messages postés
6
Date d'inscription
vendredi 16 octobre 2020
Statut
Membre
Dernière intervention
17 novembre 2020

Merci pour votre réponse.
Je désire faire au plus simple, c'est à dire entrer dans la cellule le code de 13 chiffres avec la douchette, et le titre du livre apparait.
Pour cela je dois entrer manuellement la bibliothèque de l'association, mais quelle fonction faut il sur Excel pour retrouver le titre en partant du code ISBN13.
Merci
Messages postés
2552
Date d'inscription
samedi 16 février 2019
Statut
Membre
Dernière intervention
2 décembre 2020
431
Ha si vous avez déjà la base de donnée avec les correspondances entre les ISBN et les titres, c'est plus simple. Si vous avez en colonne A le numéro scanné, en B vous souhaitez avoir le titre et disons en E et F une base de données avec deux colonnes (ISBN et Titre). Vous pouvez simplement mettre dans la colonne "B" une formule "RECHERCHEV"
=RECHERCHEV(A1;E1:F100;2;0)

(Bien sur la base peut être sur une autre feuille)
Si vous avez besoin de détails n'hésitez pas ;)
Messages postés
6
Date d'inscription
vendredi 16 octobre 2020
Statut
Membre
Dernière intervention
17 novembre 2020

Merci pour les informations. Cela marche bien je vais entrer la bibliothèque de l'association manuellement.
Merci encore