Aide formule Horaires en - [Résolu]

Signaler
-
Messages postés
25572
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 novembre 2020
-
Bonjour,

Je dois créer un tableau pour les horaires des employés.
Le soucis est que le moins doit apparaitre car il est retranscrit dans un autre tableau.
Avant les gens faisaient sans horaires ce qui était compliqué surtout que ce ne sont pas des spécialistes d'excel.

Il faut vraiment pour exemple si les eheures sont en moins : -38

Une personne du forum m'a aidé mais j'ai de nouveau besoin d'une réponse car même si sa formule fonctionne parfaitement je n'arrive pas à la décortiquer et à la modifier.

Il me faudrait inclure dans la formule le + R10 avec les m^mes conditions que l'autre. Sauf que je ne comprends pas assez cette formule pour pour pouvoir l'appliquer...

=SI(R9<$R$8;"- "&TEXTE(-(R9-$R$8);"[h]:mm");" "&TEXTE((R9-$R$8);"[h]:mm"))
C'est la cellule en R13.

https://www.cjoint.com/c/JKqoBV61r5X


Il faudrait que la cellule "balance du mois" s'additionne à celle du mois précédent.
Comme cela ne fonctionne pas je pense qu'il faut reprendre les calculs de la cellule du mois sauf que je ne comprends pas assez bien ces calculs pour faire la somme avec l'autre cellule...

Je ne sais pas si je suis claire...

Bonne journée

5 réponses

Messages postés
25572
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 novembre 2020
5 604
Bonjour
si j('ai bien compris, i faut reprendre la formule de R11 et la complèter en rajoutant R10

=SI(R9+R10<$R$8;"- "&TEXTE(-(R9+R10-$R$8);"[h]:mm");" "&TEXTE((R9+R10-$R$8);"[h]:mm"))

mais ceci suppose que R10 n'a pas de formule identique à celle-(ci qui transforme le résulta en texte et donc pas de valeur négative

sinon il faudra aussi reprendre les formules pour différencier les valeurs calculables des valeurs affichable
exemple de ce que je veux dire pour R10:
  • utiliser S10 en masqué pour entrer le nombre d'heure en décimale 1h1/2 =-1,5
  • renvoyer pour affichage en R10 la valeur avec la formule:

=SI(S10<0;"-"&TEXTE(-S10/24;"hh:mm");S10/24)
principe pour ressortir l'affichage négatif utilisable pour l'ensemble des calculs, la colonne R ne servant qu'à l'affichage et les calculs s'appuyant sur la colonne S (Sxx/24pour les calculs)
revenez si soucis
crdlmnt

Effectivement cela fonctionne si la valeur n'est pas négative

J'ai essayé avec la cellule S10, je vous ai tout mis sur le tableau en prenant exemple avec Fevrier qui est censé reprendre la valeur de Janvier et cela ne fonctionne pas.

Savez vous comment y remédier ?

https://www.cjoint.com/c/JKrjNMFwgLX

Bonne journée,
Messages postés
25572
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 novembre 2020
5 604
Voila ce que je peux vous proposer, les cellules jaunes de la colonne R ne sont là que pour l'affichage positif ou négatif, les calculs se font via la colonne S
vous pouvez soit masquer cette colonne, soit placer une police de la couleur de la cellule pour ne pas voir ces intermédiaires
Ce sont bien sur ces cellules qu'il faudra utiliser si vous avez d'autres calculs à appuyer sur ces résultats
https://mon-partage.fr/f/Hr46ZZC2/
pour info, la colonne S affiche les résultats positifs ou négatifs selon l'unité de temps d'Excel qui est le jour de 24h
revenez si soucis
crdlmnt

Merci beaucoup.

Vous venez de clôturer mon tableau... Je ne pensais pas y arriver.
Vous venez de sauver une secrétaire à la dérive.

Bonne journée et merci.
Messages postés
25572
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 novembre 2020
5 604
J'en suis ravi, surtout si près de Noël
je passe le sujet en résolu
bonne route
crdlmnt