Besoin d'aide Mfc Colorer une cellule avec condition

Signaler
Messages postés
3
Date d'inscription
jeudi 12 novembre 2020
Statut
Membre
Dernière intervention
12 novembre 2020
-
Messages postés
3
Date d'inscription
jeudi 12 novembre 2020
Statut
Membre
Dernière intervention
12 novembre 2020
-
bonjour,

j'essaye de creer un tableau excel avec mfc. Mais etant novice, je rencontre des diffucultés à le finaliser.

c'est pourquoi je me permets de vous contacter pour votre aide..

alors, j'ai cree des tableaux avec 140 cases chacun que j'alimente avec des noms, dans lequel j'ai appliqué des mfc pour que tous les doublons apparaissent en jaune, et rouge si triplons. Par contre, pour 3 noms particuliers : "x", "y" et "z", cas derogatoires, il faudrait qu'ils apparaissent en rouge au bout de la 5eme fois. Et c'est a, où cela se complique pour moi. J'espère être clair..

Qelqu'un pourrait me trouver la solution ?

merci

4 réponses

Messages postés
25600
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 novembre 2020
5 617
Bonjour
précisez ce que vous voulez? quels sont les arguments de vos MFC actuels : formules ou autre
la formule pour MFC >=5, exemple pour un champ de A1 à A140
=NB.SI($A$1:$A$140;A1)>=5
donne l format pour toutes les cellules de valeur A1si le nombre arrive à 5 ou plus
=NB.SI(A1:$A$140;A1)
donne le format à partir de la 5° édition de A1seulement
à vous lire si besoin
crdlmnt


Messages postés
3
Date d'inscription
jeudi 12 novembre 2020
Statut
Membre
Dernière intervention
12 novembre 2020

Merci de votre repinse.
Par contre, Je me suis mal exprimé. Concretement voici le tableau. En jaune sont notés les doublons, et en rouge les triplons. Cependant, le nom "cesar" qui est devenu rouge par la mfc, je souhaiterais qu'il soit jaune jusqu'à 4 fois. Et au bout de la 5eme, il deviendrait rouge, contrairement au reste qui passent en rouge, au bout de la 3eme fois.
Messages postés
25600
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 novembre 2020
5 617
alors essayez de placer en priorité dans la liste des MFC via les flèches ascenseur dans le haut de la fenêtre) une MFC avec cette formule, exemple pour une plage de A2 à G10 à adapter:
=ET(A2="césar";NB.SI($A$2:$G$10;"césar")>1;NB.SI($A$2:$G$10;"césar")<5)

et formater
en jaune
ça devrait passer césar en jaune de 2 à 4 avant de paser en rouge
mais si ça ne fonctionne pas, déposez un modèle ici avec les deux premières MFC et on essaiera d'adapter:
https://mon-partage.fr
et revenez coller le lien créé sur le site
.. et à demain
c rdlmnt
Messages postés
3
Date d'inscription
jeudi 12 novembre 2020
Statut
Membre
Dernière intervention
12 novembre 2020

Merci, on verra demain