Formule excel complexe [Résolu]

Signaler
-
 CqtKlz -
Bonjour,

Je souhaiterais inclure une formule d'alerte sur mon tableur Excel et je sens qu'il ne me manque pas grand chose pour être dans le vrai. En gros :

Si la case formation est vide alors la case actuelle ne doit rien afficher
Si la case formation a une croix et que la case date est vide alors la case actuelle doit afficher Passage
Si la case formation a une croix et que la case date affiche cette année ou l'année suivante alors la case actuelle doit afficher Renouvellement

Voici la formule que j'écris :

=SI(ESTVIDE(O7);"";SI(ET(O7="X";ESTVIDE(J7));"Passage";SI(O7="X";J7=<AUJOURDHUI()-365;"Renouvellement")))

Pouvez-vous m'aider ?

Merci d'avance.

6 réponses

Messages postés
1209
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
9 novembre 2020
119
Bonjour,

=SI(O7="";"";SI(ET(O7="X";J7="");"Passage";SI(ET(O7="X";J7>=ANNEE(AUJOURDHUI()));"Renouvellement";"")))


>
Messages postés
1209
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
9 novembre 2020

D'accord, je ne sais pas d'où cela peut venir et malheureusement, je ne peux pas inclure de capture d'écran.. Merci quand même ! :)
Messages postés
1209
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
9 novembre 2020
119 > CqtKlz
Dans ce cas, il faut faire une copie du fichier, sans y mettre de données confidentielles.

Et ensuite le partager via :

https://www.cjoint.com/
>
Messages postés
1209
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
9 novembre 2020

Je ne connaissais pas ce fonctionnement, merci de m'apprendre quelque chose supplémentaire !

https://www.cjoint.com/c/JKgoEDagycO
Messages postés
1209
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
9 novembre 2020
119 > CqtKlz
Partager une image ne sert à rien...Surtout quand il n'y a pas les adresses de colonnes & lignes !

C'est un fichier Excel qu'il faut partager.
>
Messages postés
1209
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
9 novembre 2020

https://www.cjoint.com/c/JKjiKC1kS2O avec la formule de Papyluc51
Messages postés
9794
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
9 novembre 2020
1 085
Bonjour,
Voici la formule corrigée, manquait et "ET()"
=SI(ESTVIDE(O7);"v";SI(ET(O7="X";ESTVIDE(J7));"Passage";SI(ET(O7="X";J7<=AUJOURDHUI()-365);"Renouvellement";"faux")))
Bonjour, elle ne fonctionne pas. Cela m'écrit Faux pour des dates qui sont en 2021 alors qu'elles doivent être en Renouvellement et Faux à la place d'être vides... Merci quand même ! :)
Messages postés
2854
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
9 novembre 2020
772
Bonjour,

Pas bien compris pour le renouvellement ?

Si la mention "Renouvellement" doit s'afficher pendant toute l'année qui précède la date inscrite en J7, alors :

=SI(O7="";"";SI(ET(O7="X";J7="");"Passage";SI(ET(O7="X";AUJOURDHUI()>=MOIS.DECALER(J7;-12));"Renouvellement";"")))


Cordialement
Bonjour, votre formule fonctionne mieux mais elle m'écrit Renouvellement pour toutes les dates inférieures et supérieures au lieu de le mettre pour l'année en cours et N+1. Merci quand même ! :)
Messages postés
2854
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
9 novembre 2020
772
Faudrait peut-être mieux expliquer en donnant des exemples

MOIS.DECALER c'est date à date en tenant compte des années bissextiles
En prenant la date d'aujourd'hui (6/11/2020) et si la date en J7 est 6/11/2021 ; la formule marque "renouvellement" pour toute la période du 6/11/20 au 6/11/21. Si J7 est 7/11/21 la cellule reste vide jusqu'à demain.

A moins que finalement il faut marquer renouvellement pendant 1 an à partir de la date inscrite en J7.

A te lire

Cordialement
Pour la faire simple, voici les colonnes de mon tableau :

J7 = Formation à venir = Passage/Renouvellement/(Vide)
F7 = Expire le = jj/mm/aaaa
O7 = Catégorie 1 = X

Le Renouvellement est à prévoir pour l'année en cours et l'année suivante. Si on a un permis dépassé de 1 an par exemple, nous devons faire un Passage, également si nous n'avons pas de date mais que la O7 est coché. Et si le permis est valable jusqu'en 2023, la case J7 doit être vide jusqu'à l'ouverture du fichier en 2022.

Je ne sais pas si cela est plus clair pour vous.
Messages postés
1209
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
9 novembre 2020
119 >
Messages postés
2854
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
9 novembre 2020

Salutations PapyLuc , il me semble que tu comprends mieux le sujet que moi !

Perso, je suis perdu ou alors qq chose m'a échappé !?

Je quitte le sujet, en sachant pertinemment que tu trouveras avant moi ce qui convient le mieux à CqtKlz
Messages postés
2854
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
9 novembre 2020
772 >
Messages postés
1209
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
9 novembre 2020

Salutations Yoyo

L'exemple que j'ai mis est fait avec la première formule que j'ai envoyée (mon message #3).
La réponse de notre demandeur m'a conforté dans mon idée.

@ CqtKlz

Je viens de constater en relisant la formule que tu l'as mal recopiée (message #14)
=SI(ESTVIDE(O7),"",SI(ET(O7="X",ESTVIDE(J7)),"Passage",SI(ET(O7="X",MOIS.DECALER(AUJOURDHUI(),J7)),"Renouvellement")))
La partie en gras doit s'inscrire AUJOURDHUI()>=MOIS.DECALER(J7;-12).
C'est à dire tu retires 12 mois à la date en J7 et Renouvellement s'inscrit quand la date du jour est égale ou dépasse se décalage et reste jusqu'à la date en J7.
Et puis tu inscris toujours ESTVIDE(O7) ?? Est-ce à dire que O7="" qui est plus rapide à inscrire ne fonctionne pas sur ton Excel ?? Ça me parait étonnant !!.

On peut même réduire la formule à
=SI(O7="";"";SI(J7="";"Passage";SI(AUJOURDHUI()>=MOIS.DECALER(J7;-12);"Renouvellement";"")))

qui fonctionne tout au bien.

Cordialement
>
Messages postés
2854
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
9 novembre 2020

Bonjour, je ne savais pas où inclure le mois décaler dans la formule. Je viens de copier coller celle que vous m'avez noté et j'ai toujours Renouvellement d'inscrit dès qu'il y a une date dans mon tableau...

https://www.cjoint.com/c/JKjiKC1kS2O
Messages postés
2854
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
9 novembre 2020
772 > CqtKlz
Bonjour,

Tu as incrémenté la colonne F sur H et sur G mais la référence expire le doit être décalée de 2 colonnes donc il faut modifier

en G7
=SI(P7="";"";SI(L7="";"Passage";SI(AUJOURDHUI()>=MOIS.DECALER(L7;-12);"Renouvellement";"")))


en H7
=SI(Q7="";"";SI(N7="";"Passage";SI(AUJOURDHUI()>=MOIS.DECALER(N7;-12);"Renouvellement";"")))


Ton fichier en retour avec les corrections

https://www.cjoint.com/c/JKjjk7HkSTS

Cordialement
>
Messages postés
2854
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
9 novembre 2020

AHHHHHH D'accord, faute d'inattention de ma part alors, cela fonctionne mieux en effet. Merci beaucoup pour votre aide !!! Je vous souhaite une agréable journée et une bonne continuation ! :)
Messages postés
9794
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
9 novembre 2020
1 085
Bonjour,
Désolé, je quitte le poste.
D'accord merci à vous, bon week-end :)