Impossible de faire un mount de partage cifs [Résolu]

Signaler
-
Messages postés
29413
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
11 novembre 2020
-
Bonjour

pour vous expliquer mon probléme

j'ai une VM sous W7 qui partage un dossier 1

j'ai un hote en centos 7 qui monte en cifs le partage vers un répertoire via la commande :

mount.cifs \\\\ipVM/dataVM /root/input -o user=monuser,password=""



quand je lance la commande manuellement cela fonctionne

j'ai a coté un script dans le init.d qui lance au démarrage la vm en plein ecran

#Script de lancement VM
#
#
#NOM_DE_LA_VM
DOM="maVM"

#Démarrer la VM
virsh --connect qemu:///system start $DOM &

#sleep=10

# montage partage VM/indus
mount.cifs \\\\ipVM/dataVM /root/input -o user=monuser,password=""


#Lancer la VM en plein ecran 
#on local display main screen (0)

echo "============================================" >> /var/tmp/startvm.out
echo "START VM" >> /var/tmp/startvm.out
echo "The time the script run was -->  `date`" >> /var/tmp/startvm.out


expot DISPLAY=:0
virt-viewer --connect qemu:///system -f $DOM





Le probléme c'est que j'aimerais bien que mon partage entre ma vm et mon hôte se lance en même temps que mon startvm quand le pc reboot

j'ai essayer de l'inclure dans le script cf ci dessu mais ça ne fonctionne pas .

je sais que pour le monter il faut que la machine soit démarrer elle le fait rapidement du coup j'ai fait une sleep le temps que la machine demarre mais je ne sais pas quoi faire d'autre ??

pouvez vous m'aider

3 réponses

Messages postés
29413
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
11 novembre 2020
6 972
Bonjour,

Pourquoi tu ne montes pas ta partition cifs dans
/etc/fstab
? De plus, pour éviter de faire apparaître le mot de passe de l'utlisateur dans le script, il serait mieux de l'externaliser dans un fichier dédié avec des droits restreints, comme expliqué ici.

Enfin, le point de montage n'est pas dans un répertoire standard (on devrait en l'occurrence le mettre dans
/media
ou
/mnt
en toute rigueur, quitte à créer par la suite un lien symbolique). Appelons par exemple
/media/partage
.

sudo mkdir -p /media/partage


Dans ton cas : crée
/root/.smbcredentials
e.g. avec la commande
sudo gedit /root/.smbcredentials
et mets dedans :

username=MonNom
password=MonMotDePasse
domain=DOMAINE


Sauve, quitte, et corrige les droits :

sudo chmod 600 /root/.smbcredentials


De même corrige
/etc/fstab
pour y ajouter la ligne suivante en fin de fichier :

//ipvm/dataVM /media/partage cifs credentials=/root/.smbcredentials,iocharset=utf8 0 0


Sauve, quitte, et monte ton disque :

sudo mount /media/partage


Ensuite, si tu veux retrouver la hiérarchie que tu évoquais, tu peux créer un lien symbolique :

ln -s /media/partage /root/input


Bonne chance
Bonjour

Merci pour ton aide pour le fichiers de credentials. Oui, je sais tout çan aucun soucis. Je voulais le faire après, pour le moment je fait des tests.

Pour
/etc/fstab
, j'ai lu ça sur le net, mais il faut que ma VM ait démarré avant de monter le point de montage, non ?? Et vu qu'elle démarre après que l'utilisateur ait rentré son mot de passe, c'est un peu tôt ?
Messages postés
29413
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
11 novembre 2020
6 972 > tom45
Bonjour,

Merci de soigner l'orthographe et la ponctuation.


En fait
/etc/fstab
peut monter un point de montage au démarrage si l'option auto est indiquée. En l'absence de cette option,
/etc/fstab
permet de sous entendre la plupart des paramètres à passer à mount (en gros si tu fais
mount /mon/point/de/montage
,
mount
retrouvera le device et les paramètres manquants à l'aide de
/etc/fstab
). Donc rien ne t'empêche de déclarer ton point de montage même si ta VM n'est pas encore démarrée.

Ensuite, pour que le
mount
fonctionne, il faut bien sûr que la VM soit démarrée. Ce qui signifie que c'est plus le script qui lance ta VM qui doit, une fois celle-ci lancée, déclencher la commande
mount
...

Bonne chance
j'ai essayé de A a Z

quand je fait le mount ça fonctionne par contre quand je redémarre ça ne fonctionne pas

je pense que ce n'est pas possible de monter un point si il ne détecte pas la VM mais peut étre que je me trompe ??? avez vous une idée ?

si je fait dmsg
il me renvoi une reeur mount 113

cifs mount error 113 = No route to host
Possible de fermer le sujet svp

j'ai fait autrement en passant par un script

Merci
Messages postés
29413
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
11 novembre 2020
6 972
Pour basculer un sujet en résolu, voir ce lien. Je m'en occupe.

Et pour finir de répondre à ton message, comme je le disais dans mon précédent message, c'est à ton script de (1) lancer la VM (2) monter le volume partagé. En effet,
/etc/fstab
sert juste à déclarer comment faire le
mount
, ce qui évite de hardcoder cette information dans ton script.

Bonne continuation
je sais fermer un sujet en temps normal mais je n'ai pas l'option la mais, merci


pour le script oui en faire j'ai fait une boucle pour tester tant que pas monter essayer et ça marche
Messages postés
29413
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
11 novembre 2020
6 972
Généralement pour pouvoir fermer un sujet il faut un compte CCM. Oui effectivement faire une boucle comme tu le proposes est une manière de faire, merci pour cette précision et bonne continuation.