Calcul d'heures

Signaler
Messages postés
2
Date d'inscription
lundi 12 octobre 2020
Statut
Membre
Dernière intervention
12 octobre 2020
-
Messages postés
25370
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2020
-
Bonjour,
Je joins le tableau d'heures d'un salarié sur une base de 39 heures sachant que le vendredi nous terminons à 17 heures mais qu'il peut y avoir des heures sup entre 12 et 14 heures
et le soir.
Je ne trouve pas la formule qui pourra reconnaitre que le vendredi sera une journée de 7 heures et qu'au delà il y aura des heures supplémentaires
Je ne sais pas comment joindre mon fichier
Pouvez-vous m'aider
Bien à vous
Cathyt

3 réponses

Messages postés
9578
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
12 octobre 2020
1 921
Bonjour

1) Tu vas dans http://cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien
en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse tu fais "Coller".

RQ. N'oublies pas d'y ajouter des explications et des exemples de résultat attendu

Cdlmnt
Messages postés
1062
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
13 octobre 2020
107
Bonjour,
pour joindre le fichier :

https://www.cjoint.com/
Messages postés
25370
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2020
5 522
Bonjour
je ne sais pas comment vous notez les heures en (hh:mm ou décimal) , mais pour le principe, pour détecter si un horaire est de 7 ou 8 heures selon le jour de la semaine, (version HH:MM) si date en A2
=SI(JOURSEM(A2;2)=5;7/24;8/24)
et donc pour les heures sup avec pour l'exemple la date en A2 et les heures en B2 en C2

=B2-SI(JOURSEM(A2;2)=5;7/24;8/24)
mais si vous avez des horaires inférieures au maxi, vous pouvez écrire:
=SI(B2-SI(JOURSEM(A2;2)=5;7/24;8/24)<0;0;B2-SI(JOURSEM(A2;2)=5;7/24;8/24))
qui renverra 0 si égal ou moins que l'horaire du jour
crdlmnt