Problème compatibilité

Signaler
Messages postés
5
Date d'inscription
jeudi 8 octobre 2020
Statut
Membre
Dernière intervention
9 octobre 2020
-
Messages postés
5
Date d'inscription
jeudi 8 octobre 2020
Statut
Membre
Dernière intervention
9 octobre 2020
-
Bonjour,

J'ai fais une formule sur excel 2019 et lorsque je passe sur 2016 la formule m'affiche #VALEUR!.
Voici la formule =SI(NB.SI(Feuil2!H9;"*SS*");I;"").
Le I est un ensemble de chiffre que j'ai nommé I et lorsque du coup sur cette case H9 s'affiche SS dans la case de la formule on m'affiche #VALEUR!.
Sur ma version lorsque j'écris =I pour afficher tout les chiffres que j'ai sélectionné les chiffres ce déroule sur la colonne pour tous les afficher mais lorsque je le fais sur la version 2016 ça m'affiche qu'un seul chiffre.

Je ne sais plus quoi faire pour régler ce problème aidez-moi s'il vous plait!
Merci à vous

1 réponse

Messages postés
1134
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
23 octobre 2020
113
Bonjour,
pourquoi NB.SI pour une plage de seulement 1 cellule ?!

quelle est la condition du SI ? Car là il n'y en a pas !

Si on garde cette formule, ce serait plutôt qq du genre :

Le I doit être entre guillemets puisque c'est du texte

=SI(NB.SI(Feuil2!H:H;"*SS*")>1;"I";"")

Messages postés
5
Date d'inscription
jeudi 8 octobre 2020
Statut
Membre
Dernière intervention
9 octobre 2020
>
Messages postés
513
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
20 octobre 2020

Bonjour,

Voilà c’est ça en gros j’aimerais que selon le choix fais dans une liste déroulante Feuil2!G9 il y a une certaine liste déroulante qui est activé avec un nombre de chiffre défini dans la cellule Feuil2!H9
Cordialement
Messages postés
513
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
20 octobre 2020
23 >
Messages postés
5
Date d'inscription
jeudi 8 octobre 2020
Statut
Membre
Dernière intervention
9 octobre 2020

Quelque chose comme ça ?
https://www.cjoint.com/c/JJiqAWavHAh

Cordialement
Messages postés
5
Date d'inscription
jeudi 8 octobre 2020
Statut
Membre
Dernière intervention
9 octobre 2020
>
Messages postés
513
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
20 octobre 2020

Exactement
Comment avez vous fais ça ?
Messages postés
513
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
20 octobre 2020
23 >
Messages postés
5
Date d'inscription
jeudi 8 octobre 2020
Statut
Membre
Dernière intervention
9 octobre 2020

En Feuil3, colonne A tu listes toutes tes chaines de caractères voulues, en face en colonne B tu mets les noms des plages nommées correspondantes qui doivent déjà) exister quelque part dans ton fichier.
En feuil2 cellule H9 tu fais la validation de données Liste avec comme formule :
=INDIRECT(RECHERCHEV($G$9;Feuil3!$A$1:$B$3;2;FAUX))

La fonction RECHERCHEV remplace avantageusement ton énorme Formule avec des SI.
La plage $A$1:$B$3 est à adapter à la taille finale de ce tableau de correspondance qui peut être situé sur tout autre feuille.

Cordialement
Messages postés
5
Date d'inscription
jeudi 8 octobre 2020
Statut
Membre
Dernière intervention
9 octobre 2020
>
Messages postés
513
Date d'inscription
jeudi 18 juillet 2019
Statut
Membre
Dernière intervention
20 octobre 2020

C'est parfait je te remercie pour ton aide.

Cordialement