Problème démarrage suite MAJ Ubuntu 20.04 ce WE

Signaler
-
 alec0907 -
Bonjour,
J'ai installé il y a quelque temps UBUNTU 20.04.
Ce WE j'ai installé les mises à jour.
Depuis cette installation, au démarrage UBUNTU ne lance plus l'interface graphique, j'ai un curseur clignotant sur fond noir.
En faisant Ctrl+alt+F1 suivi de CTRL+alt+F2, l'interface graphique démarre normalement.
J'ai installé boot-repair, je l'ai exécuté mais ça n'a rien changé.
J'ai essayé de modifier le GRUB, avec Grub customizer, je l'ai paramétré sur une ancienne entrée par défaut, l'interface graphique se lançait bien mais impossible de s'y loguer.
J'ai, du en mode terminal aller modifier manuellement le fichier de démarrage grub
remettre Ubuntu, avec Linux 5.4.0-48-generic dans default=
j'avais mis le Ubuntu, avec Linux 5.4.0-47-generic avec grub customizer.

Bref, j'ai une nouvelle version d'Ubuntu qui tourne mais qui ne se lance pas automatiquement en mode graphique.
Ce ne doit pas être grand chose, mais j'ai besoin d'aide.
Merci pour vos réponses.


Configuration: Linux / Chrome 85.0.4183.121

3 réponses

Pour les experts, voici le fichier d'info généré par boot-repair:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
boot-repair-4ppa125 [20201006_2250]

============================== Boot Info Summary ===============================

=> Windows 7/8/2012 is installed in the MBR of /dev/sda.
=> No boot loader is installed in the MBR of /dev/sdb.

sda1: __________________________________________________________________________

File system: ntfs
Boot sector type: Windows 7/2008: NTFS
Boot sector info: No errors found in the Boot Parameter Block.
Operating System:
Boot files:

sdb1: __________________________________________________________________________

File system: vfat
Boot sector type: FAT32
Boot sector info: No errors found in the Boot Parameter Block.
Operating System:
Boot files: /efi/BOOT/bkpbootx64.efi /efi/BOOT/bootx64.efi
/efi/BOOT/fbx64.efi /efi/BOOT/grubx64.efi
/efi/BOOT/mmx64.efi /efi/ubuntu/grubx64.efi
/efi/ubuntu/mmx64.efi /efi/ubuntu/shimx64.efi
/efi/ubuntu/grub.cfg

sdb2: __________________________________________________________________________

File system: ext4
Boot sector type: -
Boot sector info:
Operating System: Ubuntu 20.04.1 LTS
Boot files: /boot/grub/grub.cfg /etc/fstab /etc/default/grub


================================ 1 OS detected =================================

OS#1: L'OS actuellement utilisé - Ubuntu 20.04.1 LTS CurrentSession on sdb2

============================ Architecture/Host Info ============================

CPU architecture: 64-bit
BOOT_IMAGE of the installed session in use:
/boot/vmlinuz-5.4.0-48-generic root=UUID=586e3e66-e7ca-4710-a440-85b3d5e92e5c ro quiet splash vt.handoff=7


===================================== UEFI =====================================

BIOS is EFI-compatible, and is setup in EFI-mode for this installed-session.
SecureBoot disabled.

efibootmgr -v
BootCurrent: 0002
Timeout: 1 seconds
BootOrder: 0002,0000
Boot0000* Windows Boot Manager VenHw(99e275e7-75a0-4b37-a2e6-c5385e6c00cb)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...r................
Boot0002* ubuntu HD(1,GPT,b9a01cb1-5a09-4fba-b304-838057fe64e5,0x800,0x100000)/File(\EFI\UBUNTU\SHIMX64.EFI)

78415fb8fb9b909f8029858113f1335f sdb1/BOOT/bkpbootx64.efi
78415fb8fb9b909f8029858113f1335f sdb1/BOOT/bootx64.efi
2895d47544fd587b26c7e29be1295c27 sdb1/BOOT/fbx64.efi
114bd85eec32e3162958ea034020821d sdb1/BOOT/grubx64.efi
dc3c47be2f78a78e5e57d097ae6c5c84 sdb1/BOOT/mmx64.efi
114bd85eec32e3162958ea034020821d sdb1/ubuntu/grubx64.efi
dc3c47be2f78a78e5e57d097ae6c5c84 sdb1/ubuntu/mmx64.efi
78415fb8fb9b909f8029858113f1335f sdb1/ubuntu/shimx64.efi


============================= Drive/Partition Info =============================

Disks info: ____________________________________________________________________

sdb : is-GPT, no-BIOSboot, has---ESP, not-usb, not-mmc, has-os, 2048 sectors * 512 bytes
sda : notGPT, no-BIOSboot, has-noESP, not-usb, not-mmc, no-os, 2048 sectors * 512 bytes

Partitions info (1/3): _________________________________________________________

sdb2 : is-os, 64, apt-get, signed grub-pc grub-efi , grub2, grub-install, grubenv-ok, update-grub, farbios
sda1 : no-os, 32, nopakmgr, no-docgrub, nogrub, nogrubinstall, no-grubenv, noupdategrub, farbios
sdb1 : no-os, 32, nopakmgr, no-docgrub, nogrub, nogrubinstall, no-grubenv, noupdategrub, not-far

Partitions info (2/3): _________________________________________________________

sdb2 : isnotESP, fstab-has-goodEFI, no-nt, no-winload, no-recov-nor-hid, no-bmgr, notwinboot
sda1 : isnotESP, part-has-no-fstab, no-nt, no-winload, no-recov-nor-hid, no-bmgr, notwinboot
sdb1 : is---ESP, part-has-no-fstab, no-nt, no-winload, no-recov-nor-hid, no-bmgr, notwinboot

Partitions info (3/3): _________________________________________________________

sdb2 : not-sepboot, with-boot, fstab-without-boot, not-sep-usr, with--usr, fstab-without-usr, std-grub.d, sdb
sda1 : not-sepboot, no-boot, part-has-no-fstab, not-sep-usr, no---usr, part-has-no-fstab, std-grub.d, sda
sdb1 : not-sepboot, no-boot, part-has-no-fstab, not-sep-usr, no---usr, part-has-no-fstab, std-grub.d, sdb

fdisk -l (filtered): ___________________________________________________________

Disk sda: 119.25 GiB, 128035676160 bytes, 250069680 sectors
Disk identifier: 0x7d5ab7ee
Boot Start End Sectors Size Id Type
sda1 2048 250066943 250064896 119.2G 7 HPFS/NTFS/exFAT
Disk sdb: 238.49 GiB, 256060514304 bytes, 500118192 sectors
Disk identifier: 3C572E11-3E7D-4645-AD47-C8598395CB0F
Start End Sectors Size Type
sdb1 2048 1050623 1048576 512M EFI System
sdb2 1050624 500117503 499066880 238G Linux filesystem

parted -lm (filtered): _________________________________________________________

sda:128GB:scsi:512:512:msdos:ATA SanDisk SDSSDHP1:;
1:1049kB:128GB:128GB:ntfs::;
sdb:256GB:scsi:512:512:gpt:ATA LITEON S960 256:;
1:1049kB:538MB:537MB:fat32:EFI System Partition:boot, esp;
2:538MB:256GB:256GB:ext4::;

blkid (filtered): ______________________________________________________________

NAME FSTYPE UUID PARTUUID LABEL PARTLABEL
sda
└─sda1 ntfs 2A1A02001A01C9B1 7d5ab7ee-01 DATA ALEC
sdb
├─sdb1 vfat 1B01-4E39 b9a01cb1-5a09-4fba-b304-838057fe64e5 EFI System Partition
└─sdb2 ext4 586e3e66-e7ca-4710-a440-85b3d5e92e5c 58714ace-ff47-46c7-b140-7eec8f49c0c6

df (filtered): _________________________________________________________________

Avail Use% Mounted on
sda1 44.3G 63% /mnt/2A1A02001A01C9B1
sdb2 167G 23% /

Mount options: __________________________________________________________________

sda1 rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096
sdb2 rw,relatime,errors=remount-ro

===================== sdb1/efi/ubuntu/grub.cfg (filtered) ======================

search.fs_uuid 586e3e66-e7ca-4710-a440-85b3d5e92e5c root hd1,gpt2
set prefix=($root)'/boot/grub'
configfile $prefix/grub.cfg

====================== sdb2/boot/grub/grub.cfg (filtered) ======================

Ubuntu 586e3e66-e7ca-4710-a440-85b3d5e92e5c
Ubuntu, avec Linux 5.4.0-48-generic 586e3e66-e7ca-4710-a440-85b3d5e92e5c
Ubuntu, avec Linux 5.4.0-47-generic 586e3e66-e7ca-4710-a440-85b3d5e92e5c
### END /etc/grub.d/30_os-prober ###
UEFI Firmware Settings uefi-firmware
### END /etc/grub.d/30_uefi-firmware ###

========================== sdb2/etc/fstab (filtered) ===========================

# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda2 during installation
UUID=586e3e66-e7ca-4710-a440-85b3d5e92e5c / ext4 errors=remount-ro 0 1
# /boot/efi was on /dev/sda1 during installation
/swapfile none swap sw 0 0
/dev/disk/by-uuid/2A1A02001A01C9B1 /mnt/2A1A02001A01C9B1 auto nosuid,nodev,nofail,x-gvfs-show 0 0
UUID=1B01-4E39 /boot/efi vfat defaults 0 1

======================= sdb2/etc/default/grub (filtered) =======================

GRUB_DEFAULT="Options avancées pour Ubuntu>Ubuntu, avec Linux 5.4.0-47-generic"
GRUB_TIMEOUT_STYLE="hidden"
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_SAVEDEFAULT="false"
==================== sdb2: Location of files loaded by Grub ====================

GiB - GB File Fragment(s)
215.131843567 = 230.996058112 boot/grub/grub.cfg 1
141.902477264 = 152.366624768 boot/vmlinuz 1
131.355594635 = 141.041995776 boot/vmlinuz-5.4.0-47-generic 1
141.902477264 = 152.366624768 boot/vmlinuz-5.4.0-48-generic 1
131.355594635 = 141.041995776 boot/vmlinuz.old 1
130.984321594 = 140.643344384 boot/initrd.img 4
10.203346252 = 10.955759616 boot/initrd.img-5.4.0-47-generic 2
130.984321594 = 140.643344384 boot/initrd.img-5.4.0-48-generic 4
10.203346252 = 10.955759616 boot/initrd.img.old 2

===================== sdb2: ls -l /etc/grub.d/ (filtered) ======================

-rwxr-xr-x 1 root root 17622 août 17 16:04 10_linux
-rwxr-xr-x 1 root root 42359 août 17 16:04 10_linux_zfs
-rwxr-xr-x 1 root root 12894 juil. 31 02:34 20_linux_xen
-rwxr-xr-x 1 root root 12059 juil. 31 02:34 30_os-prober
-rwxr-xr-x 1 root root 1424 juil. 31 02:34 30_uefi-firmware
-rwxr-xr-x 1 root root 214 juil. 31 02:34 40_custom
-rwxr-xr-x 1 root root 216 juil. 31 02:34 41_custom
drwxr-xr-x 4 root root 4096 oct. 6 22:16 backup


Suggested repair: ______________________________________________________________

The default repair of the Boot-Repair utility would reinstall the grub-efi-amd64-signed of
sdb2,
using the following options: sdb1/boot/efi,
Additional repair would be performed: unhide-bootmenu-10s use-standard-efi-file restore-efi-backups

Final advice in case of suggested repair: ______________________________________


Please do not forget to make your UEFI firmware boot on the L'OS actuellement utilisé - Ubuntu 20.04.1 LTS CurrentSession entry (sdb1/efi/****/shim****.efi (**** will be updated in the final message) file) !
Salut,

Ton installation me semble normale pour démarrer correctement si ton bios est réglé pour booter en uefi par défaut. Ton tiret clignotant est peut-être dû au fait qu'il est réglé pour démarrer d'abord en Legacy, puis en UEFI. Donc, le démarrage pourrait rester bloqué faute de partition active. Essaie par conséquent de vérifier déjà ce point avant d'aller plus avant.

Sinon, il faudra s'orienter vers un problème de pilote graphique, et voir si en ajoutant l'option "nomodeset', on résout provisoirement le problème.

PS. Je vois des traces de Windows en NVram. S'il existe encore (sur sda), il doit ne plus démarrer.
Mon Pc était fourni avec un Windows 10.
J'ai installé un ubuntu avec une clé bootable,, j'avais pourtant bien forcé le formatage complet, je ne sais pas pourquoi windows traine encore dans le menu boot.
Je viens de vérifier mon Bios, le CSM est bien disable...