Transformer un format texte en date avec condition [Résolu]

Signaler
Messages postés
3
Date d'inscription
mardi 6 octobre 2020
Statut
Membre
Dernière intervention
6 octobre 2020
-
Messages postés
3
Date d'inscription
mardi 6 octobre 2020
Statut
Membre
Dernière intervention
6 octobre 2020
-
Bonjour,
J'ai utilisé la formule suivante : =DATE(GAUCHE(C2,4),STXT(C2,5,2),DROITE(C2,2)) afin de transformer ma saisie 20190502 en 02/05/2019. C'est super cela fonctionne très bien.
Mais j'aimerai ajouter une condition à cette formule. Il arrive parfois dans ma saisie que je ne puisse saisir la donnée jour et donc la donnée à transformer est 201905 en 05/2019.
Savez-vous comment puis-je écrire la formule qui lorsqu'est saisi 20190502 cela se transforme en 02/05/2019 sinon si est saisie 201905 cela se transforme 05/2019 ?

J'espère avoir réussi à être claire.

Merci pour votre aide

3 réponses

Messages postés
1062
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
13 octobre 2020
107
Bonjour,
en testant le nombre de caractère dans C2 et en combinant la fonction SI :

=SI(NBCAR(C2)=8;DATE(GAUCHE(C2;4);STXT(C2;5;2);DROITE(C2;2));DROITE(C2;2)&"/"&GAUCHE(C2;4))

Messages postés
3
Date d'inscription
mardi 6 octobre 2020
Statut
Membre
Dernière intervention
6 octobre 2020

Super merci beaucoup cela fonctionne très bien.
Je me permets une autre demande est-ce que cette formule peut-elle être appliquée dans la même cellule ou je saisie la donnée.
Je saisie dans la cellule A1 20190502 et lorsque je fais entrée la donnée se transforme en 02/05/2019 dans la même cellule A1.

Encore merci pour votre aide
Messages postés
1062
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
13 octobre 2020
107
C'est NON !

On ne peut pas utiliser la même cellule pour mettre une valeur et une formule car l'une des 2 écrasant l'autre.
Messages postés
3
Date d'inscription
mardi 6 octobre 2020
Statut
Membre
Dernière intervention
6 octobre 2020

ok merci pour le retour.

Bien à vous !