Formule Excel [Résolu]

Signaler
Messages postés
3
Date d'inscription
lundi 5 octobre 2020
Statut
Membre
Dernière intervention
6 octobre 2020
-
Messages postés
3
Date d'inscription
lundi 5 octobre 2020
Statut
Membre
Dernière intervention
6 octobre 2020
-
Bonjour,

Je souhaiterai trouver une formule excel pour trouver une date d'ancienneté mais j'ai trois données : la date d'entrée/la date du jour/et la date de sortie éventuelle.
J'ai trouvé la formule si la date de sortie n'est pas renseignée donc pour les personnes toujours présentes à ce jour:
=SI(ESTVIDE(cellule "date de sortie");DATEDIF(cellule"date d'entrée";$C$2cellule date du jour;"y"))

Mais je n'arrive pas à trouver la formule me permettant de savoir quelle est l'ancienneté
entre date d'entrée/date d'aujourd'hui ou si date de sortie ancienneté entre date d'entrée et date de sortie.

Je vous remercie pour votre aide

Configuration: Windows / Chrome 85.0.4183.121

4 réponses

Messages postés
855
Date d'inscription
lundi 22 septembre 2008
Statut
Membre
Dernière intervention
20 octobre 2020
175
Bonjour,
Il te suffit de rallonger ta formule en utilisant la fonction SI()
https://mon-partage.fr/f/LFNjGeRm/
Messages postés
3
Date d'inscription
lundi 5 octobre 2020
Statut
Membre
Dernière intervention
6 octobre 2020

Merci beaucoup ça fonctionne
Messages postés
2810
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
24 octobre 2020
384
Bonjour à tous,

Tes explications ne me paraissent pas claires ....
C'est quoi la différence entre ta formule
=SI(ESTVIDE(cellule "date de sortie");DATEDIF(cellule"date d'entrée";$C$2cellule date du jour;"y"))
et ton autre demande :
"Mais je n'arrive pas à trouver la formule me permettant de savoir quelle est l'ancienneté entre date d'entrée/date d'aujourd'hui "

Autrement, tu peux essayer :
=SI(ESTVIDE(cellule "date de sortie");DATEDIF(cellule"date d'entrée";$C$2cellule date du jour;"y");DATEDIF(cellule"date d'entrée";cellule "date de sortie";"y"))


Crdlmt
Messages postés
29874
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
25 octobre 2020
6 866
Bonjour,

Voir
=DATEDIF(A1;SI(ESTVIDE(B1);AUJOURDHUI();B1);"y") 

Messages postés
1138
Date d'inscription
samedi 2 février 2019
Statut
Membre
Dernière intervention
25 octobre 2020
113
Bonjour,
qq chose comme ça :

=SI(cellule "date de sortie"="";DATEDIF(cellule"date d'entrée";$C$2cellule date du jour;"y");SI(cellule "date de sortie"<>"";DATEDIF(cellule"date d'entrée";$C$2cellule date de sortie;"y")))