Faire une somme en fonction d'un mois à partir de dates [Résolu]

Signaler
Messages postés
6
Date d'inscription
jeudi 1 octobre 2020
Statut
Membre
Dernière intervention
1 octobre 2020
-
Messages postés
457
Date d'inscription
dimanche 7 juillet 2019
Statut
Membre
Dernière intervention
1 octobre 2020
-
Bonjour,

J'ai passé pas mal de temps à essayer de trouver la bonne formule.
Je souhaite dans les cases jaunes mettre une formule qui fasse que ça reprenne la somme de toutes les montants de la colonne C dont la date de la colonne B correspond au mois donné.
J'ai essayé avec la fonction SOMME.SI, avec SOMME.SI.ENS, avec la fonction MOIS, avec la fonction DATE. Mais je n'ai pas trouvé la bonne formule et j'imagine mal que ça ne soit pas prévu par excel...
Quelqu'un peut-il m'aider?
Merci! :)

5 réponses

Messages postés
25375
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2020
5 525
Bonjour
en E3:
=SOMMEPROD((MOIS($B$2:$B$23)=5)*($C$2:$C$23)
à adapter selon le N° calendaire du mois (5=Mai)
crdlmnt


Messages postés
6
Date d'inscription
jeudi 1 octobre 2020
Statut
Membre
Dernière intervention
1 octobre 2020

Ok, merci Vaucluse.
ça m'avance déjà un peu, je ne connaissais pas la fonction SOMMEPROD.
Par contre je me rends compte que ma question n'était pas complète, puisque dans mon cas, j'ai aussi besoin que ça puisse être avec des années différentes.
J'ai refait mon tableau exemple. Tu saurais comment faire comme ça?
Messages postés
23558
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
6 404
Bonjour à tous,

avec un TCD ça se fait tout seul sans formule.
Tableau Croisé Dynamique (TCD) : http://www.mdf-xlpages.com/modules/smartsection/item.php?itemid=109
et
http://www.mdf-xlpages.com/modules/publisher/item.php?itemid=130

Déposer un fichier de travail sur cjoint.com et coller ici le lien fourni si difficultés.
eric
Messages postés
6
Date d'inscription
jeudi 1 octobre 2020
Statut
Membre
Dernière intervention
1 octobre 2020

Je veux bien ne pas avoir à aller fouiller les TCD. Je suis pas encore au point.
Et si ma réponse s'obtient toute seule avec un TCD, il semblerait que le TCD lui, clairement, ne se fasse pas tout seul.
Une formule comme me l'a proposé Vaucluse, c'est quand même vachement plus simple (même si elle ne répond pas complètement à ma demande, qui était incomplète).
Messages postés
23558
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
6 404 >
Messages postés
6
Date d'inscription
jeudi 1 octobre 2020
Statut
Membre
Dernière intervention
1 octobre 2020

Une formule comme me l'a proposé Vaucluse, c'est quand même vachement plus simple
La preuve, tu ne sais pas faire...

Il ne faut pas voir peur des TCD.
Tu as juste à faire glisser des champs soit en ligne, soit en colonne et lui indiquer ce que tu veux compter de la même façon.
Dépose un fichier comme demandé si tu veux un exemple.
Ceci dit, tu as également tout intérêt à progresser aussi dans les formules.
eric
Messages postés
25375
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2020
5 525
Alors compléter la demande, SOMMEPROD accepte un nombre illimité d'item (l'année, la catégorie, min, maxi ect...)
à vous lire?
crdlmnt
Messages postés
6
Date d'inscription
jeudi 1 octobre 2020
Statut
Membre
Dernière intervention
1 octobre 2020

J'ai refait mon tableau. Le voilà.
Ce serait adorable si tu arrivais à me faire la formule de la case F3 par exemple.
Franchement je galère...
Messages postés
6
Date d'inscription
jeudi 1 octobre 2020
Statut
Membre
Dernière intervention
1 octobre 2020

J'AI TROUVÉ!!!!!!!
en F3, la bonne formule c'est :
=SOMMEPROD((MOIS($B$2:$B$23)=5)*(ANNEE($B$2:$B$23)=2020)*($C$2:$C$23))

Je ne comprends pas trop pourquoi c'est la fonction SOMMEPROD qui est censée multiplié, que la fonction SI qui sert plutôt à conditionné la somme si tel ou tel critère est complété (là le mois et l'année).
Mais ok.

Merci Vaucluse!
Messages postés
25375
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2020
5 525
Re
=SOMMEPROD((ANNEE($B$2:$B$23)=2020)(MOIS($B$2:$B$23)=5)*($C$2:$C$23))

et éventuellement pour associer la formule au valeur titre de chaque section:
  • entrez dans la cellule F2 la date du premier jour du mois cherché (1/5/2020)
  • formater la cellule en format personnalisé: mmmm-aa pour l'affichage
  • la formule devient:

=SOMMEPROD((ANNEE($B$2:$B$23)=ANNEE(F2))(MOIS($B$2:$B$23)=MOIS(F2))*($C$2:$C$23))
  • à transposer ben sur les autres sections avec la date en titre

Mais cela ne doit pas empêcher de suivre le conseil d'Eric et de creuser les TCD... le seul avantage des formules étant de permettre des variantes de mise en page
crdlmnt
Messages postés
457
Date d'inscription
dimanche 7 juillet 2019
Statut
Membre
Dernière intervention
1 octobre 2020
29
bonjour
il faut utiliser la fonction BDSOMME

comme c'est un peut compliqué a expliquer succintement
il faut, si tu veut mettre ton fichier en ligne pour pas ressaisir tes données

en attendant ta réponse
merci


Messages postés
6
Date d'inscription
jeudi 1 octobre 2020
Statut
Membre
Dernière intervention
1 octobre 2020

Merci Alex, mais Vaucluse m'a déjà donné la réponse.
=SOMMEPROD((ANNEE($B$2:$B$23)=ANNEE(F2))(MOIS($B$2:$B$23)=MOIS(F2))*($C$2:$C$23))

ça ça me va parfaitement.
Messages postés
457
Date d'inscription
dimanche 7 juillet 2019
Statut
Membre
Dernière intervention
1 octobre 2020
29 >
Messages postés
6
Date d'inscription
jeudi 1 octobre 2020
Statut
Membre
Dernière intervention
1 octobre 2020

ok
autant pour moi
A+