Quelle Formule Excel ? [Résolu]

Signaler
Messages postés
1
Date d'inscription
dimanche 27 septembre 2020
Statut
Membre
Dernière intervention
27 septembre 2020
-
 bwana69 -
Bonjour à tous,
En fonction du contenu de K1 (issu d'une plage de cellules B1) je souhaite que L1 attribue le contenu de A-- si le contenu de K1=contenu de B1

8 réponses

Messages postés
8324
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
8 janvier 2021
1 556
Bonjour,,
Voir ici :
https://www.commentcamarche.net/faq/37465-excel-fonctions-si-et-ou-non
Et
https://support.microsoft.com/fr-fr/office/si-si-fonction-69aed7c9-4e8a-4755-a9bc-aa8bbff73be2

Cordialement
Patrice

Personne ne peut détenir tout le savoir, c'est pour ça qu'on le partage.
Messages postés
53037
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
10 janvier 2021
15 003
Bonjour.

Ta demande
" En fonction du contenu de K1 (issu d'une plage de cellules B1) je souhaite que L1 attribue le contenu de A-- si le contenu de K1=contenu de B1 "
aurait pu se réduire à
" Je souhaite attribuer à L1 le contenu de A1 si le contenu de K1 est égal au contenu de B1 "
ou même
" Je souhaite que L1=A1 si K1=B1 "

Et la réponse est :
En L1, saisir la formule =SI(K1=B1;A1;"")
Merci Raymond,
Je me suis mal exprimé, jusqu'à là c'était à ma portée ; le but est que :
-si le contenu de K1 est similaire au contenu d'une cellule de la colonne B
-alors L1 sera égal au contenu de la cellule adjacente (A--) de celle de B ayant le dit contenu
Messages postés
2175
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
9 janvier 2021
300
bonjour,

2 formules au choix
=INDIRECT("A"&EQUIV($K$1;$B:$B;0))

ou
=INDEX($A:$B;EQUIV($K$1;$B:$B;0);1)


Cdlt
merci mais ça ne fonctionne pas #N/A
Messages postés
2175
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
9 janvier 2021
300
Quelle macro lancez-vous?

Faites du pas à pas avec F8, vous trouverez bien ce qui coince.

Sinon détaillez ce que vous faites.

EDIT:
Erreur, ceci ne vous est pas adressé
colonne A : référence
colonne B : désignation($B de 5 à 123)
colonne C : batch n°
colonne K : liste colonne B
colonne L : =A(de 5 à 123) selon présence du contenu de K
AUTANT POUR MOI, je dois signaler que je suis un peu c...
=INDEX($A:$B;EQUIV($K$1;$B:$B;0);1) FONCTIONNE

MERCI