Formule SIXT [Résolu]

Signaler
-
Messages postés
52193
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
2 septembre 2020
-
Bonjour,

Dans ma colonne A j'indique des numéros de devis ou de projet. Les numéros de devis commence par D et de projet par P, comme ci-dessous :
P20034_146_Paris = Projet
D19054_416_Belgique = Devis

J'aimerai que dans ma colonne B apparaisse "Devis" ou "Projet" selon les n° indiqué en colonne A.

J'ai essayé une formule mais dès qu'il y a un P ou un D dans la cellule ça ne fonctionne plus. La formule devrait prendre en considération uniquement la première lettre du numéro.

Dans l'attente de vos retours,
Cordialement,

Configuration: Windows / Chrome 85.0.4183.83

2 réponses

Messages postés
2755
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
30 août 2020
717
Bonsoir,

Pour prendre en considération uniquement la première lettre du code (s'il n'y a que Devis ou Projet)

=SI(A1<>"";SI(GAUCHE(A1;1)="D";"DEVIS";"PROJET");"")

S'il y a d'autres lettres

=SI(A1<>"";SI(GAUCHE(A1;1)="D";"DEVIS";SI(GAUCHE(A1;1)="P";"PROJET";SI(....etc....))),"")

Cordialement
Messages postés
52193
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
2 septembre 2020
13 971
Bonsoir IsoJ.

Attention : SIXT n'existe pas dans le vocabulaire Excel !

Quand tu nous expliques "J'ai essayé une formule ...", il devrait être évident et automatique de nous montrer quelle est cette fameuse formule, afin qu'on t'indique quelle erreur tu as pu commettre !
Sinon, tu risques fort de la faire de nouveau pour une question semblable.