Excel impossible d'obtenir une cellule vide avec = et j'ai besoin du zéro... [Résolu]

Signaler
Messages postés
5
Date d'inscription
samedi 29 août 2020
Statut
Membre
Dernière intervention
29 août 2020
-
Messages postés
5
Date d'inscription
samedi 29 août 2020
Statut
Membre
Dernière intervention
29 août 2020
-
Bonjour,

Je bute sur un truc qui a l'air simple, et je ne trouve pas la solution sur les forums.
J'ai 2 fichiers excel, disons le A (rempli par des patients) et le B (rempli par moi)
Dans les 2 fichiers A et B j'ai un système de notes qui va de 0 à 5
Le fichier A est rempli en amont par le patient, le fichier B comprend davantage de données, que je remplis lors de l'entretien.
Je souhaite par contre que les données remplies par le patient (fichier A), lorsque je les récupère, s'affichent automatiquement dans mon fichier B

J'ai utilisé dans mon fichier B le = pour récupérer le contenu des cellules du A.

Mon problème : les cellules vides du A devraient aussi rester vides dans le B, or elles sont remplacées par zéro. Et là où ça se corse, c'est que lorsque la note est zéro, j'ai besoin de la conserver dans le tableau. Or dans mon tableau B, je ne peux plus distinguer les notes à zéro des cellules vides. Quelqu'un aurait une solution, car je tourne en rond, désactiver l'affichage du zéro dans les options avancées ne convient pas, puisque j'ai des notes à zéro.... Help !

Merci d'avance de votre aide.




1 réponse

Messages postés
29695
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
30 septembre 2020
6 778
Bonjour,

Tu peux utiliser, lors de la récupération des données du fichier A, un test comme
=SI(A1<>"";A1;"")

ou
=SI(ESTVIDE(A1);"";A1)


Messages postés
5
Date d'inscription
samedi 29 août 2020
Statut
Membre
Dernière intervention
29 août 2020
>
Messages postés
29695
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
30 septembre 2020

Merci JeePee, j'ai tenté, mais en vain, ça ne change rien. Je ne pense pas m'être trompé dans la formule. Je te mets la copie d'écran, j'ai fait le test avec ta formule sur la cellule D8 du tableau de droite.
Aurais-tuune idée ?

=SI(ESTVIDE('[EPSA Questionnaire aux aidants.xlsx]Sensorialité'!$D$8);"";'[EPSA Questionnaire aux aidants.xlsx]Sensorialité'!$D$8)

Encore merci du temps que tu m'accordes.

Messages postés
29695
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
30 septembre 2020
6 778 >
Messages postés
5
Date d'inscription
samedi 29 août 2020
Statut
Membre
Dernière intervention
29 août 2020

Sur D8 il y a 0 donc normal, cela affiche 0
Messages postés
5
Date d'inscription
samedi 29 août 2020
Statut
Membre
Dernière intervention
29 août 2020
>
Messages postés
29695
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
30 septembre 2020

...... bon, là je n'ai plus qu'à me terrer de honte.... En effet, tu as parfaitement raison. Et ta formule fonctionne à merveille, je l'ai testé sur toute la colonne "D" avec réussite.
Par contre il me reste un petit problème :

Dans le tableau de droite, cellule D22 (,ombre d'items cotés) j'ai utilisé la formule NBVAL(D8:H20) qui me donne le nombre de cellules remplies, ceci afin de pouvoir calculer la moyenne (somme des notes divisé par nombre des notes).
Dans le tableau de droite, cela fonctionne parfaitement, mais dans le gauche, excel considère toujours les cases vides comme remplies. As-tu une solution pour ce point ?

Mille merci pour ton aide et bonne soirée.

Jacques.
Messages postés
29695
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
30 septembre 2020
6 778 >
Messages postés
5
Date d'inscription
samedi 29 août 2020
Statut
Membre
Dernière intervention
29 août 2020

essayer
 =NB.SI(D8:H20;">=0") 
Messages postés
5
Date d'inscription
samedi 29 août 2020
Statut
Membre
Dernière intervention
29 août 2020
>
Messages postés
29695
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
30 septembre 2020

Génial, ça marche très bien Jeepee ! Un très très grand merci, je n'arrivais pas à m'en sortir depuis 2 jours.
Bonne soirée.