Calcul de la durée d'une date à une autre (en prenant en compte les heures) [Résolu]

Signaler
Messages postés
29
Date d'inscription
vendredi 13 avril 2018
Statut
Membre
Dernière intervention
16 octobre 2020
-
Messages postés
29
Date d'inscription
vendredi 13 avril 2018
Statut
Membre
Dernière intervention
16 octobre 2020
-
Bonjour,

je cherche à faire une formule ou une méthode qui me permettrait de calculer la durée en jour entre deux cellules.

Exemple:
Cellule A2 = 15/08/2020 03:15:00
Cellule B2 = 19/08/2020 15:40:00
Cellule C2 = Combien de jour c'est écoulé entre ces deux dates ? 4,3 ?

Ah et dans l'idéal, il faudrait si possible que la cellule C2 soit dans le format date/heure
Je précise que les écarts de date sont toujours de quelques jours et ne dépasseront jamais + de 30 jours.

Merci pour votre aide.
Bien Cordialement,
Ryo

9 réponses

Messages postés
12772
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 octobre 2020
2 043
Bonjour

Le résultat n'est pas 4,3 mais un peu plus de 4,5

En faisant B2-A2 on obtient bien 4,517361111 (sur lequel on pourrait appliquer un arrondi); que veux tu de plus ?

Cdlmnt
Via

Messages postés
2799
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
14 octobre 2020
381
Bonjour à tous,

Essaye :

=ENT(B2-A2)&" jour(s)"&TEXTE((B2-A2)-ENT(B2-A2);"hh:mm")&" heure(s)"


Crdlmt
Messages postés
29
Date d'inscription
vendredi 13 avril 2018
Statut
Membre
Dernière intervention
16 octobre 2020

Merci DjiDji59430 c'est exactement ce qui m'intéresse.
Et si je souhaite le calcul uniquement en heure:minute ?

ce qui pourrait par exemple donner 36:15

Merci encore
Bien Cordialement,
Messages postés
17247
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
14 octobre 2020
4 288
Bonjour,

essaye cette formule qui décompte les années, mois, jours et heures,

=SI(ENT(A2)<1;MOD(A2-B2;1);SI(DATEDIF(A2;B2;"y")>0;DATEDIF(A2;B2;"y")&" an(s) ";"")&SI(DATEDIF(A2;B2;"ym")>0;DATEDIF(A2;B2;"ym")&" mois ";"")&DATEDIF(A2;B2;"md")+SI(B2-ENT(B2)>A2-ENT(A2);1;0)-SI(B2-ENT(B2)<A2-ENT(A2);1;0)&" jour(s)"&" et "&TEXTE(MOD((B2-ENT(B2))-(A2-ENT(A2));1);"hh:mm:ss"))


mais que tu pourras la raccourcir pour ne traiter que les jours et heures si tu le souhaites
=DATEDIF(A2;B2;"md")+SI(B2-ENT(B2)>A2-ENT(A2);1;0)-SI(B2-ENT(B2)<A2-ENT(A2);1;0)&" jour(s)"&" et "&TEXTE(MOD((B2-ENT(B2))-(A2-ENT(A2));1);"hh:mm:ss")

Uniquement le calcul des heures
=TEXTE(MOD((B2-ENT(B2))-(A2-ENT(A2));1);"hh:mm:ss")*1 et formater la cellule en heures:minutes etc...

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Messages postés
29
Date d'inscription
vendredi 13 avril 2018
Statut
Membre
Dernière intervention
16 octobre 2020

Merci Mike mais la formule bug visiblement. Elle me rajoute un jour à chaque fois.
La formule de DjiDji59430 est celle qui se rapproche le plus de mon besoin.

Merci pour votre aide
Messages postés
17247
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
14 octobre 2020
4 288
Re,

Exact voilà corrigé pour les années, mois, jours et heures

=SI(ENT(A2)<1;MOD(A2-B2;1);SI(DATEDIF(A2;B2;"y")>0;DATEDIF(A2;B2;"y")&" an(s) ";"")&SI(DATEDIF(A2;B2;"ym")>0;DATEDIF(A2;B2;"ym")&" mois ";"")&DATEDIF(A2;B2;"md")&" jour(s)"&" et "&TEXTE(MOD((B2-ENT(B2))-(A2-ENT(A2));1);"hh:mm:ss"))

juste pour les jours et heures
=DATEDIF(A2;B2;"md")&" jour(s)"&" et "&TEXTE(MOD((B2-ENT(B2))-(A2-ENT(A2));1);"hh:mm:ss")

et uniquement pour les heures
=TEXTE(MOD((B2-ENT(B2))-(A2-ENT(A2));1);"hh:mm:ss")*1 et formater la cellule en heures:minutes etc...


A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Messages postés
29
Date d'inscription
vendredi 13 avril 2018
Statut
Membre
Dernière intervention
16 octobre 2020

Merci Mike,

la formule juste pour les jours et heures fonctionne 04 jours et 12:25:00

par contre la formule uniquement pour les heures ne fonctionne pas.
Exemple :
Cellule A2 = 15/08/2020 03:15:00
Cellule B2 = 19/08/2020 15:40:00

Votre formule =TEXTE(MOD((B2-ENT(B2))-(A2-ENT(A2));1);"hh:mm:ss")*1
me sort 12:25 alors que j'attends 108:25

A moins que je me trompe ?
Messages postés
17247
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
14 octobre 2020
4 288
Re,
Je pensais que tu ne voulais que les heures, alors que tu veux les jours en heures + les heures
Alors
=(DATEDIF(A2:B2;"md")*24)+TEXTE(MOD((B2-ENT(A2));1);"hh:mm:ss")*1

Et tu formates la cellule [HH]:mm

Je suis à l'extérieur dans l'impossibilité de tester pour l'instant
Messages postés
17247
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
14 octobre 2020
4 288
Re,

voilà la formule corrigée et testée

=(DATEDIF(A2;B2;"md")*24)/(1*24)+TEXTE(MOD((B2-ENT(B2))-(A2-ENT(A2));1);"hh:mm:ss")*1


et formate la cellule avec ce format personnalisée
[hh]:mm:ss

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Messages postés
2799
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
14 octobre 2020
381
Bonjour à tous,

=b2-a2
formaté en [hh]:mm
Ça donne 108:25
Ça suffit si b2>a2
Alors ryo_976, ta colonne A est toujours >a la colonne B ???
Messages postés
29
Date d'inscription
vendredi 13 avril 2018
Statut
Membre
Dernière intervention
16 octobre 2020

Bonjour, cela correspond exactement ce que je recherche.
Merci pour votre aide et désolé pour ce retard de réponse de ma part

Bon weekend :)